aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOuyang Jun <ouyangj.fnst@cn.fujitsu.com>2019-07-15 00:30:48 -0700
committerOuyang Jun <ouyangj.fnst@cn.fujitsu.com>2019-07-25 20:51:26 -0700
commit1ccfd76fbdd7bb5fba6c98ddd965a00798c393dd (patch)
treef1096039ee5cd1700b18500c541f161cea51d002 /recipes-graphics
parent27eedb4555f45fd59ca5bdd3a868aaf7fc858b73 (diff)
Add a shrink agl-demo-platform version
Base on agl-demo-platform, make a shrink version for low performance board can run agl-demo-platform. Weston, hmi-framework, some APPs and some services were deleted. Using cluster-dashboard as qtwayland compositor instead of weston. Bug-AGL: SPEC-2487 Signed-off-by: Ouyang Jun <ouyangj.fnst@cn.fujitsu.com> Signed-off-by: Zhou Mingying <zhoumy@cn.fujitsu.com> Signed-off-by: Liu Wenlong <liuwl.fnst@cn.fujitsu.com> Change-Id: I96bb337f6ae157f696fc2e4fb61cdd7afc8f5109
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/kms-conf/kms-conf/kms.conf8
-rw-r--r--recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf12
-rw-r--r--recipes-graphics/kms-conf/kms-conf_1.0.bb12
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes-graphics/kms-conf/kms-conf/kms.conf b/recipes-graphics/kms-conf/kms-conf/kms.conf
new file mode 100644
index 0000000..7fa9686
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf/kms.conf
@@ -0,0 +1,8 @@
+{
+ "device": "/dev/dri/card0",
+ "outputs": [
+ {
+ "name":"HDMI-A-1"
+ }
+ ]
+}
diff --git a/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf b/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf
new file mode 100644
index 0000000..16ea328
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf
@@ -0,0 +1,12 @@
+{
+ "device": "/dev/dri/card0",
+ "outputs": [
+ {
+ "name":"HDMI-A-1"
+ },
+ {
+ "name":"LVDS1",
+ "mode":"off"
+ }
+ ]
+}
diff --git a/recipes-graphics/kms-conf/kms-conf_1.0.bb b/recipes-graphics/kms-conf/kms-conf_1.0.bb
new file mode 100644
index 0000000..b063f65
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf_1.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "kms configuration file for the qt eglfs platform"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://kms.conf \
+"
+
+do_install_append() {
+ install -d ${D}/etc
+ install -m 644 ${WORKDIR}/kms.conf ${D}/etc
+}