aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 16:46:37 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-10 13:50:24 -0500
commit251fb524e791d40cb7a7e1581649e63da9da3b08 (patch)
tree1c39d533cb1a7318b83146a0e43e563654f0f6fb /recipes-graphics
parent7ea4459ecd58198e4932db3f41fadecf0024325c (diff)
Define instrument cluster demo platform. This layer is similar to meta-agl-demo, except it defines a small platform for the instrument cluster demo, based on the agl-profile-cluster-qt5 profile. There is a "agl-cluster-demo" feature defined to enable building the platform. At the moment, only qemux86-64 and Minnowboard turbot versions have been built and tested. Other architectures should be feasible, but the agl-cluster-demo-receiver application needs some further development to support non-Intel platforms, as currently it is using the vaapisink gstreamer plug-in. Change-Id: I217608a1ecc9678d5d55a95c65f3ab6f10d5b54f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-ini-conf.bbappend23
-rw-r--r--recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg4
-rw-r--r--recipes-graphics/wayland/weston-ini-conf/virtual-landscape.cfg3
3 files changed, 30 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-ini-conf.bbappend b/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 0000000..6879975
--- /dev/null
+++ b/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,23 @@
+# Remove all rotated portrait mode config fragments, and add our own
+# instead, as the cluster demo display is landscape orientation.
+# NOTES:
+# (1) Cannot over-ride virtual.cfg simply by having a copy here and
+# getting it picked up via our FILESEXTRAPATHS_prepend due to AGL's
+# layer priority scheme (this layer is lower priority than
+# meta-agl-bsp), so need to remove it and add a replacement.
+# (2) The HDMI-A-1 config here uses a transform of 180 degrees to work
+# with the monitor setup in the AGL demo hardware platform. The
+# virtual-landscape.cfg is left unrotated, since it's used with
+# QEMU on the desktop.
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_remove = " \
+ file://hdmi-a-1-270.cfg \
+ file://hdmi-a-1-90.cfg \
+ file://virtual.cfg \
+"
+SRC_URI += " \
+ file://hdmi-a-1-180.cfg \
+ file://virtual-landscape.cfg \
+"
diff --git a/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg b/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg
new file mode 100644
index 0000000..7648c77
--- /dev/null
+++ b/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg
@@ -0,0 +1,4 @@
+# A display is connected to HDMI-A-1
+[output]
+name=HDMI-A-1
+transform=180
diff --git a/recipes-graphics/wayland/weston-ini-conf/virtual-landscape.cfg b/recipes-graphics/wayland/weston-ini-conf/virtual-landscape.cfg
new file mode 100644
index 0000000..d692536
--- /dev/null
+++ b/recipes-graphics/wayland/weston-ini-conf/virtual-landscape.cfg
@@ -0,0 +1,3 @@
+[output]
+name=Virtual-1
+mode=1920x1080