aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-03 18:03:05 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-03 23:07:17 +0000
commit728764b79d6027b7d91cbb80e0ea690ba3c737d2 (patch)
treeebb815cf818758751eae1169004eca062c4c16e6 /recipes-platform
parent46a5c08387cb501cb2b70e7cffb6d7518cbf0cbe (diff)
Add support for CAN driven speeds for the demo dashboardicefish_8.99.5icefish/8.99.58.99.5
Changes include: - Update cluster-dashboard recipe to pull in libqtappfw for signal-composer support - Add signal-composer and required low-can and gps bindings to agl-cluster-demo-platform image - Add recipe to install configuration file that tells the cluster-dashboard app to use signal-composer vehicle and engine speed events instead of running the default animation loop, and a new agl-cluster-demo-preload feature template that drives adding the recipe to the image for demo purposes. Bug-AGL: SPEC-3045 Change-Id: I193f9fd764b7610eaacc4c524522552bcc1e7ccc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
index 3b0c91c..3256fb6 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
@@ -26,14 +26,21 @@ AGL_APPS = " \
AGL_APIS = " \
agl-service-windowmanager \
+ agl-service-can-low-level \
+ agl-service-gps \
+ agl-service-signal-composer \
"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-preload", "cluster-dashboard-demo-config", "",d)}"
+
RDEPENDS_${PN}_append = " \
wayland-ivi-extension \
cluster-windowmanager-conf \
hmi-debug \
+ can-utils \
libva-utils \
linux-firmware-ralink \
${AGL_APPS} \
${AGL_APIS} \
+ ${DEMO_PRELOAD} \
"