aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb b/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
new file mode 100644
index 0000000..fd99a77
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Cross SDK of AGL Distribution for Cluster profile Demo"
+
+DESCRIPTION = "SDK image for AGL Distribution for Cluster profile Demo. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+require agl-cluster-demo-platform.bb
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES_append = " dev-pkgs"
+IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+
+inherit populate_sdk populate_sdk_qt5
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+
+# Add libvcard to the SDK to support libqtappfw
+TOOLCHAIN_TARGET_TASK += " \
+ libvcard-dev \
+ libvcard-staticdev \
+ "