summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 23:18:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-01 12:20:23 +0200
commit505f771bd855e929d50844668dc79aa35d92dea8 (patch)
tree6e3d4c0cd3fd8ad6bd22fc2b0bbf4c4f0862d124
parent98326a92c016606d71fd48cb1738247f3a0b58b4 (diff)
A change was backported to the stable series and we now need to adapt the version check. v3: Removed duplicates put in by devtool and simplified the recipe. Bug-AGL: SPEC-4802 Change-Id: I7fb54e6e344151116d7d3c0743518ca139699f3a Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-kernel/most/files/0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch23
-rw-r--r--recipes-kernel/most/most.bb17
-rw-r--r--recipes-kernel/most/most.bbappend17
3 files changed, 39 insertions, 18 deletions
diff --git a/recipes-kernel/most/files/0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch b/recipes-kernel/most/files/0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch
new file mode 100644
index 00000000..7edaa34f
--- /dev/null
+++ b/recipes-kernel/most/files/0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch
@@ -0,0 +1,23 @@
+From 18aeaf3abf9080174a7a820ac1a50839e6d6b0ca Mon Sep 17 00:00:00 2001
+From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+Date: Wed, 31 May 2023 23:12:59 +0200
+Subject: [PATCH] Fix LINUX_VERSION_CODE check for dim2_hdm
+
+Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+---
+ driver/hdm-dim2/dim2_hdm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/driver/hdm-dim2/dim2_hdm.c b/driver/hdm-dim2/dim2_hdm.c
+index fc02c6b..c1a2e71 100644
+--- a/hdm-dim2/dim2_hdm.c
++++ b/hdm-dim2/dim2_hdm.c
+@@ -54,7 +54,7 @@ MODULE_PARM_DESC(fcnt, "Num of frames per sub-buffer for sync channels as a powe
+ static DEFINE_SPINLOCK(dim_lock);
+
+ static void dim2_tasklet_fn(unsigned long data);
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(5,9,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,4,235)
+ static DECLARE_TASKLET(dim2_tasklet, dim2_tasklet_fn, 0);
+ #else
+ static DECLARE_TASKLET_OLD(dim2_tasklet, dim2_tasklet_fn);
diff --git a/recipes-kernel/most/most.bb b/recipes-kernel/most/most.bb
index f709a6d9..855d9251 100644
--- a/recipes-kernel/most/most.bb
+++ b/recipes-kernel/most/most.bb
@@ -6,7 +6,22 @@ inherit module
PV = "0.1"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH} \
+ file://0002-src-most-add-auto-conf-feature.patch \
+ file://0003-core-remove-kernel-log-for-MBO-status.patch \
+ file://0004-most-video-set-device_caps.patch \
+ file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
+ file://0006-dim2-fix-startup-sequence.patch \
+ file://0007-dim2-use-device-tree.patch \
+ file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
+ file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
+ file://0010-backport-usb-setup-timer.patch \
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
+ file://0012-Fix-build-with-5.4-kernel.patch \
+ file://0013-Fix-build-with-5.7-kernel.patch \
+ file://0014-Fix-build-with-5.9-kernel.patch \
+ file://0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch \
+ "
S = "${WORKDIR}/git/driver"
SRCREV = "e4dbbaf9e7652efaed0df3e0aab4464f5f228573"
diff --git a/recipes-kernel/most/most.bbappend b/recipes-kernel/most/most.bbappend
deleted file mode 100644
index af7ea687..00000000
--- a/recipes-kernel/most/most.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI:append = " \
- file://0002-src-most-add-auto-conf-feature.patch \
- file://0003-core-remove-kernel-log-for-MBO-status.patch \
- file://0004-most-video-set-device_caps.patch \
- file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
- file://0006-dim2-fix-startup-sequence.patch \
- file://0007-dim2-use-device-tree.patch \
- file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
- file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
- file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
- file://0012-Fix-build-with-5.4-kernel.patch \
- file://0013-Fix-build-with-5.7-kernel.patch \
- file://0014-Fix-build-with-5.9-kernel.patch \
-"