summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-18 20:40:31 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 14:29:37 +0000
commit0300d09b49aabb5878a08522dae0ef0329f34d0a (patch)
tree370b7990a7647ad5ed5c4dac145ee492231173c8
parentab0668e3a0762397f9b98a9d3eb81ba688670aad (diff)
Make cluster dashboard KUKSA.val server configurable
Add CLUSTER_DEMO_VISS_HOSTNAME variables to the cluster-dashboard and flutter-cluster-dashboard recipes and tweak the installed configuration files to use the address it specifies. This provides a hook for tweaking the configuration for e.g. running in the guest VMs in the QEMU+KVM demo. This may need to be tweaked down the road to use something like multiple packages + the alternatives mechanism instead. Bug-AGL: SPEC-4618 Change-Id: I3798987566d681eac59e8c4b9c1f2423d950b2ba Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 5109016c566a4a46e4a85f2c7b9dfcd6b8540233)
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb3
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 7d19b122..b28e6487 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -28,6 +28,8 @@ S = "${WORKDIR}/git"
inherit pkgconfig cmake_qt5
+CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+
do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
@@ -39,6 +41,7 @@ do_install:append() {
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ sed -i "s/^server = .*/server = \"${CLUSTER_DEMO_VISS_HOSTNAME}\"/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.conf
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 7e360d98..054c0066 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -30,6 +30,8 @@ OPENROUTE_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
inherit flutter-app update-alternatives
+CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+
APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
@@ -45,6 +47,7 @@ do_install:append() {
install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml \
${D}${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.default
install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+ sed -i "s/^hostname: .*/hostname: ${CLUSTER_DEMO_VISS_HOSTNAME}/" ${D}${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.demo
install -m 0755 -d ${D}${sysconfdir}/default/
echo 'OPENROUTE_API_KEY:${OPENROUTE_API_KEY}' >> ${D}${sysconfdir}/default/openroutekey