summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-03-29 14:36:14 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-03-29 14:39:16 -0700
commit155ab788720321b2cbfafb2cd78787265034ec47 (patch)
tree3277d2d3fdcab440e106ae9088e42acfd85227d0
parent6c06df12d65f84bbd5f4896e30b0726cabaacb46 (diff)
lightmediascanner: add missing character sets to RDEPENDS
This change fixes the following errors during scanning which produced invalid id3 results ERROR: could not add conversion charset 'UTF-16BE': Invalid argument ERROR: could not add conversion charset 'UTF-16LE': Invalid argument ERROR: could not add conversion charset 'Latin1': Invalid argument Bug-AGL: SPEC-1241 Change-Id: I67045575d6d198fb0b767c01701853244361b329 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
index cd4389e7..cbd740f8 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
@@ -3,3 +3,6 @@ PACKAGECONFIG[mp4] = "--enable-mp4,--disable-mp4,libmp4v2"
# add support MP3 because of the format of music files for AGL CES/ALS2017 Demo
PACKAGECONFIG_append = " id3 mp4"
+
+# add required character sets for id3 tag scanning
+RDEPENDS_${PN}_append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"