summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-11 16:16:15 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 09:15:45 +0000
commit1b7b7213e7a77d35b30cea990dfe03f32c0f5bea (patch)
treea29ec72ed7a9ee4b8944e5f28037f18691e8c0d7
parent50f330e3d09bffcfe070fc5ec30a6a47ceeb45df (diff)
Ensure all layers do pass yocto-check-layer and run-yocto-check-layer.sh scripts
Ensure the layers do pass again and that the scripts are up-to-date. Bug-AGL: SPEC-4680 Bug-AGL: SPEC-4685 Change-Id: I65cc70f657c9c56e396764699930cfa74d893364 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-graphics/libvncserver/libvncserver_0.9.14.bb12
l---------scripts/ci-yocto-check-layer.sh1
-rwxr-xr-xscripts/run-yocto-check-layer-all-layers.sh56
-rwxr-xr-xscripts/run-yocto-check-layer.sh43
5 files changed, 41 insertions, 73 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index cafd30ad..501ab809 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -16,4 +16,4 @@ BBFILES_DYNAMIC += " \
LAYERSERIES_COMPAT_agldemo = "kirkstone"
-LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer meta-flutter"
+LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer meta-flutter meta-python2 meta-app-framework multimedia-layer"
diff --git a/recipes-graphics/libvncserver/libvncserver_0.9.14.bb b/recipes-graphics/libvncserver/libvncserver_0.9.14.bb
index 50bdad57..32788171 100644
--- a/recipes-graphics/libvncserver/libvncserver_0.9.14.bb
+++ b/recipes-graphics/libvncserver/libvncserver_0.9.14.bb
@@ -5,6 +5,13 @@ PRIORITY = "optional"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
+SRC_URI = "git://github.com/LibVNC/libvncserver;branch=master;protocol=https"
+SRCREV := "10e9eb75f73e973725dc75c373de5d89807af028"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
# ffmpeg support is not currently compatible with ffmpeg 5.0
PACKAGECONFIG ??= " \
24bpp \
@@ -42,11 +49,6 @@ PACKAGECONFIG[zlib] = "-DWITH_ZLIB=ON,-DWITH_ZLIB=OFF,zlib"
PACKAGE_BEFORE_PN = "libvncclient"
FILES:libvncclient = "${libdir}/libvncclient.*"
-inherit cmake
-SRC_URI = "git://github.com/LibVNC/libvncserver;branch=master;protocol=https"
-SRCREV = "10e9eb75f73e973725dc75c373de5d89807af028"
-
-S = "${WORKDIR}/git"
EXTRA_OECMAKE = "-DMAKE_INSTALL_LIBDIR=${libdir}"
diff --git a/scripts/ci-yocto-check-layer.sh b/scripts/ci-yocto-check-layer.sh
new file mode 120000
index 00000000..fa7c110b
--- /dev/null
+++ b/scripts/ci-yocto-check-layer.sh
@@ -0,0 +1 @@
+run-yocto-check-layer.sh \ No newline at end of file
diff --git a/scripts/run-yocto-check-layer-all-layers.sh b/scripts/run-yocto-check-layer-all-layers.sh
deleted file mode 100755
index 08db5d12..00000000
--- a/scripts/run-yocto-check-layer-all-layers.sh
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/bash
-set -x
-
-SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
-echo $SCRIPTPATH
-AGLROOT="$SCRIPTPATH/../.."
-POKYDIR="$AGLROOT/external/poky"
-TMPROOT=`mktemp -d`
-
-rm -rf ${TMPROOT}/testbuild-ycl || true
-mkdir -p ${TMPROOT}/testbuild-ycl
-cd ${TMPROOT}/testbuild-ycl
-
-source $POKYDIR/oe-init-build-env .
-
-cat << EOF >> conf/local.conf
-# just define defaults
-AGL_FEATURES ?= ""
-AGL_EXTRA_IMAGE_FSTYPES ?= ""
-
-# important settings imported from poky-agl.conf
-# we do not import
-DISTRO_FEATURES:append = " systemd"
-DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
-VIRTUAL-RUNTIME_init_manager = "systemd"
-#AGL_FEATURES += "aglcore agldemo"
-#DISTRO_FEATURES:append = " appfw"
-
-# workaround:
-#ERROR: Nothing RPROVIDES 'qtwebengine-qmlplugins' (but /home/dl9pf/AGL/master-newlayout/external/meta-qt5/recipes-qt/qt5/qt5-creator_git.bb RDEPENDS on or otherwise requires it)
-BBMASK += "meta-qt5/recipes-qt/qt5/qt5-creator_git.bb"
-
-EOF
-
-
-yocto-check-layer -d \
- --dependency \
- $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-openembedded/meta-python \
- $AGLROOT/external/meta-openembedded/meta-networking \
- $AGLROOT/external/meta-security \
- $AGLROOT/external/meta-openembedded/meta-perl \
- $AGLROOT/meta-agl/meta-agl-core \
- $AGLROOT/external/meta-qt5 \
- --additional-layers \
- $AGLROOT/external/meta-qt5 \
- $AGLROOT/external/meta-python2 \
- -- \
- $AGLROOT/meta-agl-demo
-
-cat ${TMPROOT}/testbuild-ycl/conf/bblayers.conf
-
-[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl
-
-exit 0
diff --git a/scripts/run-yocto-check-layer.sh b/scripts/run-yocto-check-layer.sh
index 4b9e8182..378df20a 100755
--- a/scripts/run-yocto-check-layer.sh
+++ b/scripts/run-yocto-check-layer.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-set -x
+#set -x
SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
echo $SCRIPTPATH
@@ -19,18 +19,44 @@ AGL_FEATURES ?= ""
AGL_EXTRA_IMAGE_FSTYPES ?= ""
# important settings imported from poky-agl.conf
-# we do not import
-DISTRO_FEATURES:append = " systemd smack"
+# we cannot import the distro config right away
+# as the initial values are poky only till the layer
+# is added in
+
+AGL_DEFAULT_DISTRO_FEATURES := "usrmerge largefile opengl wayland pam bluetooth bluez5 3g polkit"
+DISTRO_FEATURES:append := " systemd wayland pam \${AGL_DEFAULT_DISTRO_FEATURES}"
DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
VIRTUAL-RUNTIME_init_manager = "systemd"
-EOF
+# ignore due to issue upstream
+BBMASK += "meta-flutter/recipes-graphics/toyota/ivi-homescreen_git.bb "
+
+
+# required by meta-flutter/recipes-graphics/toyota/flutter-auto_git.bb"
+LICENSE_FLAGS_ACCEPTED += "commercial"
+
+# Need to ignore as we have more recent version
+# meta-openembedded/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.13.bb
+BBMASK += "meta-openembedded/meta-oe/recipes-graphics/libvncserver/libvncserver_*"
+
+# due to this, we also ignore:
+BBMASK += "meta-oe/recipes-support/remmina/remmina_* meta-oe/recipes-graphics/x11vnc/x11vnc_* "
-yocto-check-layer \
+EOF
+
+yocto-check-layer --no-auto-dependency \
--dependency \
- $AGLROOT/external/meta-openembedded/meta-oe \
$AGLROOT/meta-agl/meta-agl-core \
+ $AGLROOT/meta-agl/meta-app-framework \
+ $AGLROOT/external/meta-openembedded/meta-oe \
+ $AGLROOT/external/meta-openembedded/meta-python \
+ $AGLROOT/external/meta-openembedded/meta-networking \
+ $AGLROOT/external/meta-openembedded/meta-multimedia \
+ $AGLROOT/external/meta-flutter \
+ $AGLROOT/external/meta-qt5 \
+ $AGLROOT/external/meta-clang \
+ $AGLROOT/external/meta-python2 \
-- \
$AGLROOT/meta-agl-demo
@@ -38,8 +64,3 @@ yocto-check-layer \
[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl
exit 0
-
- --dependency \
- $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-openembedded/meta-python \
- $AGLROOT/external/meta-openembedded/meta-networking \