summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-11-12 18:04:52 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-11-12 18:04:52 +0100
commit289ef24dfff4d7763d8eab294315502949746b7a (patch)
treeb9bdc710a97a0c034c859a6caa15eb1cd27eb6ea
parent71cc91454b8a30bdfbc4b7c48374fd1b0fef2e30 (diff)
The file needs to be copied manually and not by the class itself. Only the activation is handled automagically. Change-Id: I524dde40e0017898e03a4c72cdf30a72a72a9f49 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-kernel/sllin/sllin.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-kernel/sllin/sllin.bb b/recipes-kernel/sllin/sllin.bb
index f3176a8e..f7ffea96 100644
--- a/recipes-kernel/sllin/sllin.bb
+++ b/recipes-kernel/sllin/sllin.bb
@@ -31,6 +31,8 @@ SYSTEMD_SERVICE_${PN} = "sllin-demo.service"
do_install_append () {
install -d 644 ${D}/${bindir}
install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
}
FILES_${PN}_append = " ${bindir}/start_lin_demo.sh"