summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2019-11-29 10:17:56 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-12-04 14:04:17 +0100
commit31e355495a4ae354e79a7eccb8a75a91ba9c0a05 (patch)
treecdad8019039bb3fbd83c2ab3ccbee3bf9637c658
parent40d3bcf14728d53a3ab9df790b4eee8f6296bc65 (diff)
Move packages from agl-core to agl-ivi
Bug-AGL: SPEC-2500 v2: rename packagegroup-agl-ivi-navigation, remove duplicate Change-Id: I4bbd4474768a84291e94877f3a6b5b4d5a3edc58 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-platform/images/agl-image-ivi-crosssdk.bb2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb9
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb5
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb17
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb30
5 files changed, 56 insertions, 7 deletions
diff --git a/recipes-platform/images/agl-image-ivi-crosssdk.bb b/recipes-platform/images/agl-image-ivi-crosssdk.bb
new file mode 100644
index 00000000..93537feb
--- /dev/null
+++ b/recipes-platform/images/agl-image-ivi-crosssdk.bb
@@ -0,0 +1,2 @@
+# just for backward compatibility
+require recipes-platform/images/agl-image-minimal-crosssdk.bb
diff --git a/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb b/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
index 0edc600c..acaa405a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
@@ -18,14 +18,9 @@ RDEPENDS_${PN} += "\
packagegroup-agl-ivi-connectivity \
packagegroup-agl-ivi-graphics \
packagegroup-agl-ivi-multimedia \
+ packagegroup-agl-ivi-navigation \
+ packagegroup-agl-ivi-services \
"
-# packagegroup-agl-ivi-automotive \
-# packagegroup-agl-ivi-speech-services \
-# packagegroup-agl-ivi-navi-lbs \
-# packagegroup-agl-ivi-security \
-# packagegroup-agl-ivi-os-commonlibs \
-# packagegroup-agl-ivi-kernel \
-#
RDEPENDS_${PN} += "\
agl-login-manager \
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
index 2d45986d..17d0d4b6 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
@@ -11,5 +11,10 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
+ bluez5-obex \
+ ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
+ rtl-sdr \
+ neard \
+ neardal-tools \
ofono \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
new file mode 100644
index 00000000..90daf923
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
@@ -0,0 +1,17 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Navigation and Location-Based Services Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-navigation \
+ "
+
+RDEPENDS_${PN} += "\
+ gpsd \
+ virtual/gpsd-conf \
+ geoclue \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
new file mode 100644
index 00000000..bc30aedf
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The minimal set of packages for AGL IVI Connectivity Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-services \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+agl-service-bluetooth \
+agl-service-bluetooth-map \
+agl-service-bluetooth-pbap \
+agl-service-can-low-level \
+agl-service-geoclue \
+agl-service-geofence \
+agl-service-gps \
+agl-service-identity-agent \
+agl-service-iiodevices \
+agl-service-mediascanner \
+agl-service-navigation \
+agl-service-nfc \
+agl-service-signal-composer \
+agl-service-steering-wheel \
+agl-service-unicens \
+agl-service-weather \
+high-level-viwi-service \
+ "