summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-17 12:35:21 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 14:29:37 +0000
commit348df0b19d782ce4cbebc20cd17fc0b6c9d46293 (patch)
tree5c496545aabd0d568fe2d0dc2de77673e2ee9bc4
parent20fcd4159ce4602329278e1c3af44d5ed44417bb (diff)
agl-kvm-demo-platform: update guests
Switch default guest images to Flutter based demo platform images. As well, the simple-can-simulator is added to the host to allow testing or demos. Bug-AGL: SPEC-4618 Change-Id: I2c57ca0ade168c2c3dfae8718e891f9af40e4d88 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 8b0fed47d196a938b44784d1fc8eaa25c36f84ca)
-rw-r--r--recipes-graphics/wayland/weston-ini-conf_agldemo.inc4
-rw-r--r--recipes-platform/images/agl-kvm-demo-platform.bb5
2 files changed, 5 insertions, 4 deletions
diff --git a/recipes-graphics/wayland/weston-ini-conf_agldemo.inc b/recipes-graphics/wayland/weston-ini-conf_agldemo.inc
index 21d80145..003d411c 100644
--- a/recipes-graphics/wayland/weston-ini-conf_agldemo.inc
+++ b/recipes-graphics/wayland/weston-ini-conf_agldemo.inc
@@ -2,8 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/weston-ini-conf:"
SRC_URI += "file://weston.ini.kvm.in"
-GUEST_VM1_IMAGE ?= "agl-demo-platform"
-GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform"
+GUEST_VM1_IMAGE ?= "agl-ivi-demo-platform-flutter"
+GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform-flutter"
do_compile:append() {
# Put all of our cfg files together for a default portrait
diff --git a/recipes-platform/images/agl-kvm-demo-platform.bb b/recipes-platform/images/agl-kvm-demo-platform.bb
index e2f5fd29..d04186b2 100644
--- a/recipes-platform/images/agl-kvm-demo-platform.bb
+++ b/recipes-platform/images/agl-kvm-demo-platform.bb
@@ -19,6 +19,7 @@ IMAGE_INSTALL:append = " \
${QEMU_GUEST_CONFIGS} \
util-linux-taskset \
screen \
+ simple-can-simulator \
alsa-utils \
"
@@ -28,8 +29,8 @@ IMAGE_INSTALL:append = " \
GUEST_MACHINE ?= "virtio-${TUNE_ARCH}"
-GUEST_VM1_IMAGE ?= "agl-demo-platform"
-GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform"
+GUEST_VM1_IMAGE ?= "agl-ivi-demo-platform-flutter"
+GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform-flutter"
GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAGE}"