summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-05-22 18:15:01 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-25 12:53:51 +0000
commit3935b1e55f8399e446a90332e7b426614d51dda9 (patch)
treebc1309afa84589e971302bee8bd63226ecaf6920
parent9e5c86a0645e95fd3fae0a76349a7b7db9207d0a (diff)
radio: update recipe for switch to radio binding
Building the radio application has some different dependencies with the switch to using a binding instead of qtmultimedia. Update DEPENDS and RDEPENDS to reflect the changes. Bug-AGL: SPEC-581 Change-Id: I610b580f54d4348cd27ada3eaee4711f02d94df6 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index 86ffe8c5..ca75f2d7 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -3,8 +3,9 @@ DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
SECTION = "apps"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LICENSE = "Apache-2.0 & GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=http \
file://presets-ALS.conf \
@@ -17,7 +18,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtmultimedia"
+DEPENDS = "qtquickcontrols2 rtl-sdr glib-2.0 pulseaudio alsa-lib"
inherit qmake5 aglwgt
@@ -36,8 +37,3 @@ FILES_${PN} += " \
/home/root/app-data/radio/presets-*.conf \
/home/root/app-data/radio/presets.conf \
"
-
-RDEPENDS_${PN} += " \
- qtmultimedia-qmlplugins \
- qtmultimedia-rtlfm-radio-plugin \
-"