summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:11:07 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-05-31 20:41:30 +0000
commit42592b699c78f96525517386e32031b199271043 (patch)
treee6de4b1cf90dc58dd640b3ff978e5dfdef788d13
parent7b95189a63ff8aa80943ccfa36a2759d9940f0d4 (diff)
Move launcher into meta-agl-demo from meta-agl-devel
Part of the layer cleanup. v2: Fix - moved libhomescreen to meta-agl v3: packagegroup-hmi-framework is too broad and only applies to -demo atm, move here v4: agl-service-homescreen should go to profile-graphical Bug-AGL: SPEC-2450 Change-Id: I00f1fda64af1f9d78b82902438c26c7f9579ae53 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb14
-rw-r--r--recipes-demo-hmi/launcher/launcher_git.bb25
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf16
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen_git.bb26
-rw-r--r--recipes-platform/packagegroups/packagegroup-hmi-framework.bb23
5 files changed, 48 insertions, 56 deletions
diff --git a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb b/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
deleted file mode 100644
index 6b250f83..00000000
--- a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Homescreen binding and client library for application"
-DESCRIPTION = "agl-service-homescreen is the binding library"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
-SECTION = "HMI"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "dbus glib-2.0 af-binder json-c"
-
-inherit cmake aglwgt
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "6c3015a7607c45313fa10792b9914864f8c25831"
-S = "${WORKDIR}/git"
diff --git a/recipes-demo-hmi/launcher/launcher_git.bb b/recipes-demo-hmi/launcher/launcher_git.bb
new file mode 100644
index 00000000..8c3f72f6
--- /dev/null
+++ b/recipes-demo-hmi/launcher/launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibwindowmanager \
+ qlibhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf b/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf
deleted file mode 100644
index dc3852ee..00000000
--- a/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf
+++ /dev/null
@@ -1,16 +0,0 @@
-<!DOCTYPE busconfig PUBLIC
-"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
-"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy context="default">
- <!-- Allow everyone to talk to main service. We'll later add an agent to
- only share the location if user allows it. -->
- <allow send_interface="org.agl.statusbar"/>
- </policy>
-
- <policy user="root">
- <!-- Allow root to own the name on the bus -->
- <allow own="org.agl.statusbar"/>
- </policy>
-</busconfig>
-
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
deleted file mode 100644
index 1acd7af8..00000000
--- a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "AGL Home Screen Library"
-DESCRIPTION = "libhomescreen"
-HOMEPAGE = "http://docs.automotivelinux.org"
-LICENSE = "Apache-2.0"
-SECTION = "libs"
-
-BBCLASSEXTEND = " nativesdk"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "af-binder json-c"
-
-inherit cmake
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
- file://org.agl.statusbar.conf \
- "
-SRCREV = "44290c49e08fe52d6e3ed80720473577131090f4"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- mkdir -p ${D}${sysconfdir}/dbus-1/session.d
- install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
-}
-
-RDEPENDS_${PN} = "agl-service-homescreen"
diff --git a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
new file mode 100644
index 00000000..cf704e63
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -0,0 +1,23 @@
+SUMMARY = "The software for the AGL hmi framework 2017"
+DESCRIPTION = "A set of packages belong to the hmi framework 2017"
+
+LICENSE = "MIT"
+
+# need to bump manually due to:
+# - nothing provides libqthomescreenwrapper0 needed by packagegroup-hmi-framework-1.0-r0.noarch
+PR = "2"
+
+inherit packagegroup
+
+RDEPENDS_${PN} += " \
+ agl-service-windowmanager \
+ agl-service-homescreen \
+ homescreen \
+ libwindowmanager \
+ qlibwindowmanager \
+ libhomescreen \
+ qlibhomescreen \
+ runxdg \
+ hmi-debug \
+ launcher \
+"