summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:01:54 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-14 15:17:42 +0000
commit4f1fbee15a1029056a9ac3e2a1172f15c7836718 (patch)
tree401804e7fba7e46ad00d72f970d924c8a5df4ce5
parent2f58388fb015228fd17c35bf0d5ba47094738f02 (diff)
html5-mediaplayer: create recipe and add to html5 demo
Bug-AGL: SPEC-3152 Change-Id: I70ada4d6cf6da76b03bca7c2d8905f364b8a460f Signed-off-by: Lorenzo Tilve <ltilve@igalia.com> (cherry picked from commit 5000d2e090cc2c8df74a7a96804882e8e74d9bdf)
-rw-r--r--recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
new file mode 100644
index 00000000..2b143766
--- /dev/null
+++ b/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Mediaplayer Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 7feb1226..a9637228 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -23,6 +23,7 @@ AGL_APPS = " \
html5-hvac \
html5-settings \
html5-mixer \
+ html5-mediaplayer \
"
RDEPENDS_${PN}_append = " \