summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwanglu <wang_lu@dl.cn.nexty-ele.com>2019-04-22 14:12:29 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-05-07 14:05:25 +0000
commit60ce936338970715c8e6fb7de9c58af6a69e6f57 (patch)
treecf0a80a6b2baaeafa5aebc10a59ef0dd54288389
parent26b2d2b962ae30f0ae2ca7015f339ead70c3947d (diff)
Add recipe for apps/settings-log-utils
Bug-AGL:SPEC-2214 Change-Id: I16734e79f7cc2029baffa5fef42f9fd7537659ea Signed-off-by: wanglu <wang_lu@dl.cn.nexty-ele.com>
-rw-r--r--recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb b/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb
new file mode 100644
index 00000000..90dc0bee
--- /dev/null
+++ b/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "App for log record"
+DESCRIPTION = "AGL HMI Application for demonstrating Log Record on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings-log-utils"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings-log-utils;protocol=https;branch=master"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets opencv boost"
+DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+
+# runtime dependencies
+RDEPENDS_${PN} += " \
+ agl-service-bluetooth \
+ agl-service-network"
+
+inherit qmake5 aglwgt