summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-05-30 19:11:37 -0400
committerScott Murray <scott.murray@konsulko.com>2022-05-31 23:19:54 +0000
commit65dcec684dc39dbfa8073b39f91f5a49db143e10 (patch)
tree4298b3ae5b9a6f4cf79a3e5d674789ae323a97f7
parent797bcf304890120d1e81dd1f5726c7de23da51cb (diff)
kuksa-viss-client: add recipe for python3-websockets dependency
The recent addition of the kuksa-viss-client recipe missed adding an updated recipe for python3-websockets to match the dependency on the 10.x version of websockets that the 0.2.1 version has. This was missed during testing with kuksa-dbc-feeder as it seems to not have the same dependency chain that the kuksa_viss_client tool does. To allow testing and debugging with kuksa_viss_client, add a backport of the python3-websockets 10.2 recipe from meta-python's kirkstone branch. Bug-AGL: SPEC-4405 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I1c91b2f26c9e451cf9f06005b69f2f8b88d9c318
-rw-r--r--recipes-devtools/python/python3-websockets_10.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-websockets_10.2.bb b/recipes-devtools/python/python3-websockets_10.2.bb
new file mode 100644
index 00000000..c8179df5
--- /dev/null
+++ b/recipes-devtools/python/python3-websockets_10.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
+HOMEPAGE = "https://github.com/aaugustin/websockets"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=78c2cc91e172ca96d6f8e4a76c739ec6"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "8351c3c86b08156337b0e4ece0e3c5ec3e01fcd14e8950996832a23c99416098"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"