summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-20 16:18:55 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-21 16:31:27 +0100
commit69dabb655f1c98924a60d19cd442590ccb258ce5 (patch)
tree703e2c1d3ae81ce3728d5aa9cedc26b9248abb52
parent7bb3630d56eaf54bbb59bfac22ddca695f8d9dcd (diff)
add dependency to images
* [SPEC-424] * yocto image should use dependency to facilitate maintenance * yocto image should have its own LICENSE defined Change-Id: Ie7f2e48bab9cc194ce10e7d364e150d2678e64d6 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
-rw-r--r--README.md2
-rw-r--r--recipes-platform/images/agl-demo-platform-crosssdk.bb2
-rw-r--r--recipes-platform/images/agl-demo-platform-html5.bb33
-rw-r--r--recipes-platform/images/agl-demo-platform-html5.inc2
-rw-r--r--recipes-platform/images/agl-demo-platform-qa.bb2
-rw-r--r--recipes-platform/images/agl-demo-platform.bb77
-rw-r--r--recipes-platform/images/agl-demo-platform.inc3
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb26
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb63
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb35
10 files changed, 140 insertions, 105 deletions
diff --git a/README.md b/README.md
index 2c12d469..c8d86760 100644
--- a/README.md
+++ b/README.md
@@ -124,7 +124,7 @@ As meta-agl's design of packagegroups, ``agl-demo-platform.bb`` contains
only ``packagegroup-agl-demo-platform`` and the packages of the DEMO applications.
``agl-demo-platform`` has 4 packagegroups in it,
-``packagegroup-agl-core``, ``packagegroup-agl-ivi``,
+``packagegroup-agl-image-minimal``, ``packagegroup-agl-image-ivi``,
``packagegroup-ivi-common-core``, and ``packagegroup-agl-demo-platform``.
* packagegroup-agl-appfw*
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 97650157..b7cf3f0d 100644
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -6,6 +6,8 @@ to form a standalone cross SDK."
require agl-demo-platform.bb
+LICENSE = "MIT"
+
IMAGE_FEATURES_append = "dev-pkgs"
IMAGE_INSTALL_append = "kernel-dev"
diff --git a/recipes-platform/images/agl-demo-platform-html5.bb b/recipes-platform/images/agl-demo-platform-html5.bb
index 0088efb1..c9247a85 100644
--- a/recipes-platform/images/agl-demo-platform-html5.bb
+++ b/recipes-platform/images/agl-demo-platform-html5.bb
@@ -1,35 +1,10 @@
-# Base image
-require recipes-ivi/images/agl-image-ivi.inc
-
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
-IMAGE_FEATURES_append = " \
- "
+LICENSE = "MIT"
-# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL_append = " \
- packagegroup-agl-core \
- packagegroup-agl-ivi \
- packagegroup-ivi-common-core \
- packagegroup-agl-demo-platform \
- "
-
-# fonts
-IMAGE_TTF_FONTS = " \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- ttf-dejavu-serif \
- "
+require agl-demo-platform-html5.inc
-# add packages for OpenIVI-HTML5 demo
-IMAGE_INSTALL_append = " \
- openivi-html5 \
- linux-firmware-ath9k \
- can-utils \
- iproute2 \
- python-curses \
- dhcp-client \
- ${IMAGE_TTF_FONTS} \
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-demo-platform-html5 \
"
diff --git a/recipes-platform/images/agl-demo-platform-html5.inc b/recipes-platform/images/agl-demo-platform-html5.inc
new file mode 100644
index 00000000..3005abeb
--- /dev/null
+++ b/recipes-platform/images/agl-demo-platform-html5.inc
@@ -0,0 +1,2 @@
+# Base image
+require recipes-ivi/images/agl-image-ivi.inc
diff --git a/recipes-platform/images/agl-demo-platform-qa.bb b/recipes-platform/images/agl-demo-platform-qa.bb
index bec5e870..fa3f717d 100644
--- a/recipes-platform/images/agl-demo-platform-qa.bb
+++ b/recipes-platform/images/agl-demo-platform-qa.bb
@@ -3,6 +3,8 @@ SUMMARY = "A full set of AGL Distribution for testing as Quality Assurance"
DESCRIPTION = "A full set of AGL Distribution. This image also has additional \
packages (e.g. commandline tools) for Quality Assurance(QA)."
+LICENSE = "MIT"
+
require agl-demo-platform.bb
IMAGE_INSTALL_append = " \
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index ff64f136..297cb706 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -1,84 +1,15 @@
-# Base image
-require recipes-ivi/images/agl-image-ivi.inc
-
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
+require agl-demo-platform.inc
+
+LICENSE = "MIT"
+
IMAGE_FEATURES_append = " \
"
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL_append = " \
- packagegroup-agl-core \
- packagegroup-agl-ivi \
- packagegroup-ivi-common-core \
packagegroup-agl-demo-platform \
"
-# fonts
-IMAGE_TTF_FONTS = " \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- ttf-dejavu-serif \
- "
-
-# add packages for CES2017 demo
-# Only for porter as these kernel module sources
-# are for the 3.10.x kernel only
-MOST_DRIVERS = " "
-MOST_DRIVERS_append = " \
- aim-cdev \
- aim-network \
- aim-sound \
- aim-v4l2 \
- hdm-dim2 \
- hdm-i2c \
- hdm-usb \
- mocca-usb \
- mostcore \
- "
-
-# HVAC dependencies depend on drivers above
-IMAGE_MOST_HVAC = " "
-IMAGE_MOST_HVAC_append = " \
- ${MOST_DRIVERS} \
- unicens \
- vod-server \
- "
-
-# can-lin is a binary and only for porter :(
-IMAGE_MOST_HVAC_append_porter = " \
- can-lin \
- "
-
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-IMAGE_MAPVIEWER = " "
-IMAGE_MAPVIEWER_append_porter = " \
- mapviewer \
- mapviewer-demo \
- "
-
-IMAGE_AGL_APPS = " \
- hvac \
- mediaplayer \
- mixer \
- navigation \
- settings \
- "
-
-IMAGE_INSTALL_append = " \
- ces2017-demo \
- linux-firmware-ath9k \
- linux-firmware-ralink \
- can-utils \
- iproute2 \
- python-curses \
- dhcp-client \
- navigation \
- poiapp \
- ${IMAGE_MAPVIEWER} \
- ${IMAGE_MOST_HVAC} \
- ${IMAGE_AGL_APPS} \
- ${IMAGE_TTF_FONTS} \
- "
diff --git a/recipes-platform/images/agl-demo-platform.inc b/recipes-platform/images/agl-demo-platform.inc
new file mode 100644
index 00000000..97329130
--- /dev/null
+++ b/recipes-platform/images/agl-demo-platform.inc
@@ -0,0 +1,3 @@
+# Base image
+require recipes-ivi/images/agl-image-ivi.inc
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
new file mode 100644
index 00000000..9092b187
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-demo-platform-html5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-ivi \
+ "
+
+# add packages for demo platform (include demo apps) here
+RDEPENDS_${PN} += " \
+ packagegroup-agl-demo \
+ "
+
+# add packages for OpenIVI-HTML5 demo
+RDEPENDS_${PN} += " \
+ openivi-html5 \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 73c724d8..d3c3a436 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -12,6 +12,65 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
- packagegroup-agl-appfw \
- homescreen \
+ packagegroup-agl-image-ivi \
"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-demo \
+ "
+
+# add packages for CES2017 demo
+# Only for porter as these kernel module sources
+# are for the 3.10.x kernel only
+MOST_DRIVERS = " "
+MOST_DRIVERS_append = " \
+ aim-cdev \
+ aim-network \
+ aim-sound \
+ aim-v4l2 \
+ hdm-dim2 \
+ hdm-i2c \
+ hdm-usb \
+ mocca-usb \
+ mostcore \
+ "
+
+# HVAC dependencies depend on drivers above
+MOST_HVAC = " "
+MOST_HVAC_append = " \
+ ${MOST_DRIVERS} \
+ unicens \
+ vod-server \
+ "
+
+# can-lin is a binary and only for porter :(
+MOST_HVAC_append_porter = " \
+ can-lin \
+ "
+
+# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
+MAPVIEWER = " "
+MAPVIEWER_append_porter = " \
+ mapviewer \
+ mapviewer-demo \
+ "
+
+AGL_APPS = " \
+ hvac \
+ mediaplayer \
+ mixer \
+ navigation \
+ settings \
+ "
+
+RDEPENDS_${PN}_append = " \
+ ces2017-demo \
+ linux-firmware-ralink \
+ navigation \
+ poiapp \
+ ${MAPVIEWER} \
+ ${MOST_HVAC} \
+ ${AGL_APPS} \
+ "
+
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
new file mode 100644
index 00000000..9042de0e
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -0,0 +1,35 @@
+SUMMARY = "The software for AGL IVI DEMO profile"
+DESCRIPTION = "A set of packages belong to AGL Demo"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-demo \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-appfw \
+ homescreen \
+ "
+
+# fonts
+TTF_FONTS = " \
+ ttf-bitstream-vera \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-serif \
+ "
+
+RDEPENDS_${PN} += " \
+ linux-firmware-ath9k \
+ can-utils \
+ iproute2 \
+ python-curses \
+ dhcp-client \
+ ${TTF_FONTS} \
+ "