summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-08 15:50:30 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:32:43 -0400
commit70dc83d80169ff6398279aed074f94fc060ff361 (patch)
tree0311ebdb07676abfb32e6aba549ba2df61fd3e98
parent98596c38c74586f97e1c808c923c6064755086dc (diff)
psplash-portrait-config: add recipe
Add psplash-portrait-config recipe to install a systemd unit override for psplash-start.service that forces a 90 degree rotation for portrait mode, add add it to packagegroup-agl-demo-platform so that it takes affect in the agl-demo-platform image. Bug-AGL: SPEC-4433 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ida64df27a3a3c22bfe2eae8233ff8656800e23d0
-rw-r--r--recipes-core/psplash/files/psplash-portrait.conf3
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb20
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb1
3 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/psplash/files/psplash-portrait.conf b/recipes-core/psplash/files/psplash-portrait.conf
new file mode 100644
index 00000000..1423cf9d
--- /dev/null
+++ b/recipes-core/psplash/files/psplash-portrait.conf
@@ -0,0 +1,3 @@
+[Service]
+ExecStart=
+ExecStart=/usr/bin/psplash --angle 90
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
new file mode 100644
index 00000000..7afee442
--- /dev/null
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Systemd unit override for psplash portrait mode for the AGL Demonstrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://psplash-portrait.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "psplash"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index c7db0355..a8be87b8 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -34,4 +34,5 @@ RDEPENDS:${PN}:append = " \
qtquickcontrols2-agl-style \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
${AGL_APPS} \
+ psplash-portrait-config \
"