summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-07-10 00:23:41 +0300
committerMatt Ranostay <matt.ranostay@konsulko.com>2019-07-10 00:47:29 +0300
commit8802cca9d52860fd01043963f5fd6c9c28aec41b (patch)
tree6f624fbedd82ac6c6ebd69bfef0262b9fa7203c9
parentcacd748d8ff65621a88bd35199414423392e0f4c (diff)
recipes-demo-hmi: add messaging recipe
Add recipe to enable building of the new messaging application. Bug-AGL: SPEC-2566 Change-Id: I99dd95540a7324d21e3fec177fb7e1e076799811 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-demo-hmi/messaging/messaging_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-demo-hmi/messaging/messaging_git.bb b/recipes-demo-hmi/messaging/messaging_git.bb
new file mode 100644
index 00000000..5812cea7
--- /dev/null
+++ b/recipes-demo-hmi/messaging/messaging_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Messaging application for AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating messaging on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/messaging"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+ libqtappfw \
+ libhomescreen \
+ qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += "agl-service-bluetooth-map"