summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-07 16:37:34 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-03-08 14:50:03 +0000
commita18da0f2c0a7b9982c03cef93672a8956cb111eb (patch)
tree89ee1a5c5f80185e0712f8330d9710b87dde77ff
parent6cce1d8fcff72bd429a6f0aea23fc5666fd67878 (diff)
Restore camera-gstreamermarlin_12.93.0marlin/12.93.012.93.0
Restore an updated version of the camera-gstreamer application recipe so that those interested can build it for testing purposes. Bug-AGL: SPEC-4284 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I32ffbc2411c4898cd7fb735d603d9d1107199cec
-rw-r--r--recipes-demo/camera-gstreamer/camera-gstreamer_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb b/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb
new file mode 100644
index 00000000..e9fa575b
--- /dev/null
+++ b/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Camera gstreamer demo application"
+DESCRIPTION = "AGL demonstration of displaying incoming camera feed"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/camera-gstreamer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ wayland wayland-native \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+RDEPENDS:${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+"