summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-02-05 19:49:07 -0800
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-02-12 18:03:52 -0800
commitb803fdbe21e4324f98b53283ccffe3c1284c6378 (patch)
treeee8c69155c143578db863b84d5c0504af8bcac0f
parent899669d635086cb67f7fcdde144e96ba47c13c0b (diff)
agl-service-weather: add weather service binding recipe
Bug-AGL: SPEC-1273 Change-Id: Ic4ea8ee6aa247ab12e191f83cbb78cdb69ff97c1 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-demo-hmi/agl-service-weather/agl-service-weather_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-demo-hmi/agl-service-weather/agl-service-weather_git.bb b/recipes-demo-hmi/agl-service-weather/agl-service-weather_git.bb
new file mode 100644
index 00000000..340bbd7d
--- /dev/null
+++ b/recipes-demo-hmi/agl-service-weather/agl-service-weather_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Weather Service Binding"
+DESCRIPTION = "AGL Weather Service Binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-weather"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-weather;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c"
+RDEPENDS_${PN} = "agl-service-geoclue"
+
+inherit cmake aglwgt pkgconfig