summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-07-31 13:14:54 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-01 10:05:58 +0000
commitb8aa98a7f1abdef60391bab932eeff57690c62b7 (patch)
treeaa1af72897777c20f7b88a272d4bafc6ac12f21e
parentd45bde7ea60fcabaa6a3c746ab31895f9654f8a3 (diff)
Enable network during compile for Flutter app recipes
Explicitly enable network access during compilation in the Flutter app recipes for now to avoid hangs when building on systems where BitBake's network sandboxing is working. The underlying issue has been raised with upstream, but may take a while to resolve, so we need to work around it in the meantime. Bug-AGL: SPEC-5215 Change-Id: I8cd9cad626addd85ff77a22e221a817b09f0e73f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30152 Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb2
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index b09156bbb..2c9109c70 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -33,6 +33,8 @@ APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
+do_compile[network] = "1"
+
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 45d75b7c7..23e58afb2 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -35,6 +35,8 @@ DISABLE_BG_ANIMATION = "-DDISABLE_BKG_ANIMATION=true"
DISABLE_BG_ANIMATION:rcar-gen3 = ""
APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
+do_compile[network] = "1"
+
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service