summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-24 09:07:40 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-24 19:36:40 +0000
commitcefd5af1bbe53bf1e1c507554d50d223e171e845 (patch)
tree4bdffd55b13887732338869acc2da1d399784871
parentcfdddcb0179fe143a7a37399b0365ff871db746e (diff)
flutter-ics-homescreen: disable bg animationquillback_16.91.0quillback/16.91.016.91.0
For now, disable the background animation on all platforms except M3/H3 by passing the build time environment flag. This will be revisited to work out a runtime configuration scheme after the Quillback M1 release. Bug-AGL: SPEC-4984 Change-Id: I4938b0bb46fd04e36f4a006fb1fb4cef7f565896 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29473 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 700754e3..ae897ff8 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -27,6 +27,11 @@ APP_CONFIG = "${BPN}.json"
SYSTEMD_SERVICE:${PN} = "flutter-ics-homescreen.service"
+# Disable the background animation on all platforms except the Renesas M3/H3 for now
+DISABLE_BG_ANIMATION = "-DDISABLE_BKG_ANIMATION=true"
+DISABLE_BG_ANIMATION:rcar-gen3 = ""
+APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
+
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service