summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-06 17:26:40 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-09 08:21:18 +0000
commitdb5447e035014952483cde78ea580fafd5201896 (patch)
tree2201350a2ca177231795e7bcac8b332b4ef82349
parentcf57bd29b9bf9614d9fa7f7e80fc4a6cfbcde7a0 (diff)
Move music data inclusion into image instead of packagegroup and make it conditional
This reworks the inclusion and moves conditional parts out of the packagegroup into the image definitions. It also introduces a variable PREINSTALL_MUSIC that you can set to '1' in your conf/local.conf . Bug-AGL: SPEC-5233 Change-Id: I3eaccfc1099c9d748d485fb144a77491d41af36d Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30258 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--recipes-platform/images/agl-ivi-demo-flutter.bb4
-rw-r--r--recipes-platform/images/agl-ivi-demo-qt.bb4
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb1
3 files changed, 8 insertions, 1 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-flutter.bb b/recipes-platform/images/agl-ivi-demo-flutter.bb
index 5753d58af..3a280e6f3 100644
--- a/recipes-platform/images/agl-ivi-demo-flutter.bb
+++ b/recipes-platform/images/agl-ivi-demo-flutter.bb
@@ -5,10 +5,14 @@ SUMMARY = "AGL IVI demo Flutter image"
FLUTTER_ICS_HOMESCREEN_CONF = "flutter-ics-homescreen-conf"
ONDEMANDNAVI_CONF = "ondemandnavi-conf"
+# import default music data package if PREINSTALL_MUSIC is set to "1"
+MUSICDATA ?= "${@oe.utils.conditional("PREINSTALL_MUSIC", "1", "pre-install-music-data", "", d)}"
+
AGL_APPS_INSTALL += " \
flutter-ics-homescreen \
${FLUTTER_ICS_HOMESCREEN_CONF} \
camera-gstreamer \
ondemandnavi \
${ONDEMANDNAVI_CONF} \
+ ${MUSICDATA} \
"
diff --git a/recipes-platform/images/agl-ivi-demo-qt.bb b/recipes-platform/images/agl-ivi-demo-qt.bb
index 8fe988d06..58bab4792 100644
--- a/recipes-platform/images/agl-ivi-demo-qt.bb
+++ b/recipes-platform/images/agl-ivi-demo-qt.bb
@@ -4,6 +4,9 @@ SUMMARY = "AGL IVI demo Qt image"
ONDEMANDNAVI_CONF = "ondemandnavi-conf"
+# import default music data package if PREINSTALL_MUSIC is set to "1"
+MUSICDATA ?= "${@oe.utils.conditional("PREINSTALL_MUSIC", "1", "pre-install-music-data", "", d)}"
+
AGL_APPS_INSTALL += " \
dashboard \
hvac \
@@ -21,5 +24,6 @@ AGL_APPS_INSTALL += " \
IMAGE_INSTALL += " \
packagegroup-agl-demo-platform \
weston-terminal-conf \
+ ${MUSICDATA} \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index 78ed85782..8fdd2ea9f 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -27,6 +27,5 @@ RDEPENDS:${PN} += " \
linux-firmware-ath9k \
linux-firmware-ralink \
iproute2 \
- pre-install-music-data \
${TTF_FONTS} \
"