summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-03-03 13:13:59 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-20 10:29:58 +0000
commitddf9e96a7e1ea286a25e47de995ce9e943bee914 (patch)
tree2b3d670fcb0e17983e045242b2cfb6a0d30f9f29
parentebac35dea1de30d02c3ba2d48b91a557f9f0c989 (diff)
Add window-management-client-grpc
This adds a recipe for window-management-client-grpc for testing out the gRPC interface. This client will talk with the compositor indirectly, using the gRPC interface exposed by the grpc-proxy helper client. Bug-AGL: SPEC-4673 Change-Id: Ib1a9d14a3bd41ea64180494962f97f0d5b557c09 Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
-rw-r--r--recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb28
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
new file mode 100644
index 00000000..9dabbaa2
--- /dev/null
+++ b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Window management gRPC application"
+DESCRIPTION = "AGL demonstration of window management using gRPC"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtwayland \
+ qtwayland-native libqtappfw grpc grpc-native \
+ "
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "8b057267c4180e5648b6636f4b5b1de07f627977"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig agl-app
+
+AGL_APP_NAME = "window-management-client-grpc"
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL/window-management-client-grpc
+}
+
+RDEPENDS:${PN} += "libqtappfw qtbase-qmlplugins"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 307c4283..c4900425 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -26,6 +26,7 @@ AGL_APPS = " \
messaging \
phone \
radio \
+ window-management-client-grpc \
"
RDEPENDS:${PN}:append = " \