summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2023-05-31 18:37:12 -0700
committerScott Murray <scott.murray@konsulko.com>2023-06-01 19:00:13 -0400
commitde1dccae31b3c7c62f0e19102b7223d747f413ed (patch)
tree475006ad03e45aca7c5d456e8af3ee2795341596
parent72b82ba156081172f6d3638a1139980a094e87a0 (diff)
Flutter bbclass refactor
-Removes use of flutter bbclass runtime modes Installed modes are determined by flutter-engine package config flags. Default modes are debug, profile, and release. -Single json file based on runtime=release. If additional parameters are needed this happens as part of workspace automation. Scott Murray: - update packagegroup-agl-demo-platform-flutter Bug-AGL: SPEC-4819 Change-Id: I58fc1b30ea3367ec5f47f52b60951cf0be31dcbc Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json17
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json18
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json (renamed from recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json)4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb8
-rw-r--r--recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json11
-rw-r--r--recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json11
-rw-r--r--recipes-demo/flutter-homescreen/files/flutter-homescreen.json (renamed from recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json)2
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb8
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb10
10 files changed, 12 insertions, 79 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
deleted file mode 100644
index 3d92b45f..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
+++ /dev/null
@@ -1,17 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
- "vm_args": [
- "--observatory-host",
- "0.0.0.0",
- "--observatory-port",
- "1234"
- ],
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
deleted file mode 100644
index aca303fb..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
+++ /dev/null
@@ -1,18 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
- "vm_args": [
- "--observatory-host",
- "0.0.0.0",
- "--observatory-port",
- "1234",
- "--start-paused"
- ],
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
index eb75dc4f..4bd7429a 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
@@ -2,10 +2,10 @@
"view": [
{
"window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard/3.3.7/release",
"width": 1920,
"height": 1080,
"fullscreen": true
}
]
-} \ No newline at end of file
+}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index a1dc29f6..2effcfed 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -10,9 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://flutter_cluster_dashboard_on_bg-debug.json \
- file://flutter_cluster_dashboard_on_bg-profile.json \
- file://flutter_cluster_dashboard_on_bg-release.json \
+ file://flutter_cluster_dashboard_on_bg.json \
file://flutter-cluster-dashboard.yaml \
file://flutter-cluster-dashboard.yaml.demo \
"
@@ -32,9 +30,7 @@ inherit flutter-app update-alternatives
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
-APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json
deleted file mode 100644
index 7741e3ac..00000000
--- a/recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/flutter_homescreen",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json
deleted file mode 100644
index 128800e4..00000000
--- a/recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/flutter_homescreen",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen.json
index 544a8e55..29308d3e 100644
--- a/recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json
+++ b/recipes-demo/flutter-homescreen/files/flutter-homescreen.json
@@ -1,7 +1,7 @@
{
"view" : [ {
"window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/flutter_homescreen",
+ "bundle_path" : "/usr/share/flutter/flutter_homescreen/3.3.7/release",
"width" : 1920,
"height": 1080,
"fullscreen": true
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index e97bded1..c4142774 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -7,9 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen;protocol=https;branch=${AGL_BRANCH} \
- file://flutter-homescreen-debug.json \
- file://flutter-homescreen-profile.json \
- file://flutter-homescreen-release.json \
+ file://flutter-homescreen.json \
file://flutter-homescreen.service \
file://homescreen_config.yaml \
"
@@ -24,9 +22,7 @@ FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app
-APP_CONFIG = "flutter-homescreen-release.json"
-APP_CONFIG:class-runtimedebug = "flutter-homescreen-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter-homescreen-profile.json"
+APP_CONFIG = "flutter-homescreen.json"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-homescreen.service ${D}${systemd_user_unitdir}/flutter-homescreen.service
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index 1467c315..bf3820aa 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -39,7 +39,7 @@ IMAGE_INSTALL:append = "\
flutter-cluster-dashboard \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
cluster-demo-config-flutter \
- flutter-auto-runtimerelease \
+ flutter-auto \
"
CLANGSDK = "1"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
index fafae298..71c2d17c 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
@@ -16,11 +16,9 @@ RDEPENDS:${PN} += "\
packagegroup-agl-demo \
"
-AGL_FLUTTER_RUNTIME ?= "runtimerelease"
-
AGL_APPS = " \
- flutter-dashboard-${AGL_FLUTTER_RUNTIME} \
- flutter-hvac-${AGL_FLUTTER_RUNTIME} \
+ flutter-dashboard \
+ flutter-hvac \
ondemandnavi \
settings \
mediaplayer \
@@ -31,8 +29,8 @@ AGL_APPS = " \
RDEPENDS:${PN}:append = " \
agl-compositor \
- flutter-auto-${AGL_FLUTTER_RUNTIME} \
- flutter-homescreen-${AGL_FLUTTER_RUNTIME} \
+ flutter-auto \
+ flutter-homescreen \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \