summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2018-12-26 19:58:43 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-02-13 13:57:01 +0000
commite2154b482e2cd93be209679bcd7bad7658839890 (patch)
treedb77b71ee569316947b9008648bee6c18a667d66
parent4f9bc5b40f14be5b4f10ad729de6f2b19a4a689a (diff)
Initial Commit : AGL world wide navigation app
Navigation EG developed a new OSS navigation as the last activity. This commit is the first commit of new OSS navi app. This navigation application can navigate around the world. Change-Id: I33eebc680f46786e941628a64695dccdcbf0f960 Signed-off-by: chenwei <i37546_Chin@aisin-aw.co.jp> Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rwxr-xr-xrecipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf15
-rwxr-xr-xrecipes-demo-hmi/navigation/ondemandnavi_git.bb36
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf b/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
new file mode 100755
index 00000000..7f4d85f0
--- /dev/null
+++ b/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
@@ -0,0 +1,15 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy context="default">
+ <!-- Allow everyone to talk to main service. We'll later add an agent to
+ only share the location if user allows it. -->
+ <allow send_interface="org.agl.naviapi"/>
+ </policy>
+
+ <policy user="root">
+ <!-- Allow root to own the name on the bus -->
+ <allow own="org.agl.naviapi"/>
+ </policy>
+</busconfig>
diff --git a/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
new file mode 100755
index 00000000..52fee098
--- /dev/null
+++ b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "AGL Reference On Demand Navigation application."
+DESCRIPTION = "This application provides the function of Navigation to AGL. "
+HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+inherit qmake5 aglwgt pkgconfig
+
+SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
+ file://org.agl.naviapi.conf \
+ "
+SRCREV = "a6930c2dff988e45e18f91a2368d829c08942b30"
+
+DEPENDS += " qtbase qtquickcontrols2 \
+ qlibhomescreen \
+ qlibwindowmanager \
+ qtlocation qtaglextras \
+ "
+
+RDEPENDS_${PN} += " qtlocation \
+ flite openjtalk \
+ "
+
+RPROVIDES_${PN} = "virtual/navigation"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}/etc/dbus-1/session.d/
+ install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
+}
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+