summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-12-16 18:00:24 +0100
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-12-16 18:01:25 +0100
commite55e57c42362f651e5319caea783a28cd18dcf11 (patch)
tree3408bf044e0c91d1c59c8a67927d8de7011ef1fd
parentd412114c0cf132a77f3b3482c5440b1a1c961b77 (diff)
html5-hvac: create recipe and add to html5 demo
Bug-AGL: SPEC-2645 Change-Id: Ie4394528f8e960b5a018097a55942865ea5f4554 Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
-rw-r--r--recipes-demo-hmi/html5-hvac/html5-hvac_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb b/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
new file mode 100644
index 00000000..d45dc80d
--- /dev/null
+++ b/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 HVAC Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-hvac/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 8352b727..afedf07a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -19,6 +19,7 @@ RDEPENDS_${PN} += "\
AGL_APPS = " \
html5-launcher \
+ html5-hvac \
"
RDEPENDS_${PN}_append = " \