summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2021-04-07 17:01:14 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-05-12 08:54:16 +0000
commite96145a39d9138029306608398ba13644f6f0cf6 (patch)
treefdc9d1370f4947824d78dfba15c27caddf326646
parent4c1450800aadb7dcd26819fcc14586bd572abc56 (diff)
Restore chromium target and browser servicelamprey_11.91.0lamprey/11.91.011.91.0
- Merged chromium changes to fix build after bumping to chromium 84 - Fixed chromium install on current recipe - Restored the chromium browser service Bug-AGL: SPEC-3830 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: I5cde7972021a4200581c2e161f848bcf7d8d0458
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb1
-rw-r--r--recipes-wam/chromium/chromium-browser-service.bb19
-rw-r--r--recipes-wam/chromium/chromium.inc19
-rw-r--r--recipes-wam/chromium/chromium84_git.bb4
4 files changed, 32 insertions, 11 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
index a857a15b..cc9ed3d6 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
@@ -13,5 +13,6 @@ ALLOW_EMPTY_${PN} = "1"
# add packages for WAM
RDEPENDS_${PN} += " \
+ chromium-browser-service \
wam \
"
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
new file mode 100644
index 00000000..58177ce9
--- /dev/null
+++ b/recipes-wam/chromium/chromium-browser-service.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Chromium browser widget"
+DESCRIPTION = "Wgt packaging for running chromium installed browser"
+HOMEPAGE = "https://webosose.org"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/chromium;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+#build-time dependencies
+DEPENDS += "af-binder af-main-native chromium84"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "chromium84-browser"
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
index 31542d1e..69c9b438 100644
--- a/recipes-wam/chromium/chromium.inc
+++ b/recipes-wam/chromium/chromium.inc
@@ -39,7 +39,7 @@ BROWSER_APP_BUILD_TARGET = "chrome"
BROWSER_APPLICATION = "chromium84-browser"
BROWSER_APPLICATION_DIR = "/opt/chromium84"
-TARGET = "${WEBRUNTIME_BUILD_TARGET}"
+TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
# Skip do_install_append of webos_system_bus. It is not compatible with this component.
WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
@@ -76,7 +76,8 @@ GN_ARGS = "\
treat_warnings_as_errors=false\
is_agl=true\
use_cbe=true\
- is_chrome_cbe=false\
+ is_chrome_cbe=true\
+ is_component_build=false\
use_cups=false\
use_custom_libcxx=false\
use_kerberos=false\
@@ -239,16 +240,15 @@ configure_browser_settings() {
}
install_chromium_browser() {
+ # Install browser files
+ ${S}/depot_tools/ninja ${PARALLEL_MAKE} -C ${OUT_DIR}/${BUILD_TYPE} webos/install/default_browser
+
D_DIR=${D}${BROWSER_APPLICATION_DIR}
+ L_DIR=${D}${CBE_DATA_PATH}
install -d ${D_DIR}
+ install -d ${L_DIR}
- # Install browser files
- if [ -e "${SRC_DIR}/webos/install" ]; then
- cd ${OUT_DIR}/${BUILD_TYPE}
- xargs --arg-file=${SRC_DIR}/webos/install/default_browser/binary.list cp -R --no-dereference --preserve=mode,links -v --target-directory=${D_DIR}
- cd ${SRC_DIR}
- xargs --arg-file=${SRC_DIR}/webos/install/default_browser/runtime.list cp -R --no-dereference --preserve=mode,links -v --target-directory=${D_DIR}
- fi
+ cp -R --no-dereference --preserve=mode,links -v ${OUT_IMAGE_DIR}/${BROWSER_APPLICATION_DIR}/* ${D_DIR}
# AGL does not have PMLOG
sed -i.bak s/PmLogCtl.*// ${D_DIR}/run_webbrowser
@@ -310,6 +310,7 @@ install_webruntime() {
do_install() {
install_webruntime
+ install_chromium_browser
}
WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION = " \
diff --git a/recipes-wam/chromium/chromium84_git.bb b/recipes-wam/chromium/chromium84_git.bb
index f5d07326..7acc2f80 100644
--- a/recipes-wam/chromium/chromium84_git.bb
+++ b/recipes-wam/chromium/chromium84_git.bb
@@ -8,9 +8,9 @@ SRC_URI = "\
"
# Needed by catapult
-DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
+DEPENDS += "libhomescreen python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-SRCREV_chromium84 = "20b9dd7995c70950e45d66c7c8cc2b2487c90eb6"
+SRCREV_chromium84 = "26c9a59becc7c81ec69f23673e0d45e7e2372b1d"
SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
BROWSER_APPLICATION = "chromium84-browser"