summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2023-08-09 15:26:18 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-12-16 14:41:55 +0000
commitedd4d9c26af5626ac9fb659cca3dc03152112251 (patch)
treeff906e196200a922d86d49f5270ac8e895690faf
parent209201a46c1bdf99b3e14e6aeabedb78886787c7 (diff)
[cef] Use bundled libwayland instead of the system libpike_16.0.3pike/16.0.316.0.3
For the M108 chromium milestone it would be possible to use the use_system_libwayland and system_wayland_scanner_path gn args to make the cef recipe use system wayland and wayland-native dependencies, but those option got deprecated[1] in newer milestones and chormium defaults to use the bundled wayland. The more maintainable approach is to use the third party dependency instead of patching chromium build system. [1]: https://chromium-review.googlesource.com/c/chromium/src/+/4030440 Bug-AGL: SPEC-4871 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: I7cb22fcfb1943d6765599544069a379088053a2c Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29423 Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-wam/cef/cef_git.bb4
-rw-r--r--recipes-wam/wam/files/WebAppMgr-cef.env2
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-wam/cef/cef_git.bb b/recipes-wam/cef/cef_git.bb
index 05d22da4..86a0a93a 100644
--- a/recipes-wam/cef/cef_git.bb
+++ b/recipes-wam/cef/cef_git.bb
@@ -56,7 +56,7 @@ OUT_PATH = "${B}/out/Release_GN_${GN_TARGET_CPU}"
DIST_PATH = "${OUT_PATH}/dist/cef-minimal_${GN_TARGET_CPU}"
CEF_DATA_PATH = "${datadir}/cef"
-DEPENDS:append = " curl clang-native gperf-native wayland wayland-native dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native"
+DEPENDS:append = " curl clang-native gperf-native dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native"
do_sync[depends] += "depot-tools-wam-native:do_populate_sysroot"
do_configure[depends] += "depot-tools-wam-native:do_populate_sysroot"
@@ -188,7 +188,7 @@ GN_DEFINES:append = " \
ozone_platform_x11=false \
use_system_minigbm=true \
use_system_libdrm=true \
- use_system_libwayland=true \
+ use_system_libwayland=false \
"
GN_DEFINES:append = " \
diff --git a/recipes-wam/wam/files/WebAppMgr-cef.env b/recipes-wam/wam/files/WebAppMgr-cef.env
index 2aa604c6..557f0d48 100644
--- a/recipes-wam/wam/files/WebAppMgr-cef.env
+++ b/recipes-wam/wam/files/WebAppMgr-cef.env
@@ -72,11 +72,9 @@ WAM_SWITCHES="\
--ozone-platform=wayland \
--no-sandbox \
--use-viz-fmp-with-timeout=0 \
- --in-process-gpu \
--remote-debugging-port=9998 \
--webos-wam \
--agl-shell-appid=homescreen \
--disable-gpu-vsync \
--ignore-gpu-blocklist \
- --ignore-gpu-blacklist \
--allow-file-access-from-files"