summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-15 13:48:22 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-17 16:03:17 -0400
commitf3dc6165f647dc35b3d6cb28566d9fb7fb63eb08 (patch)
treef238f2395676a2210175d7851df4bc55c2c23e9e
parent77cdbb995c03689e4d020a1c42f5ce5a3d62cfcd (diff)
agl-cluster-demo fixes for Kirkstone
Changes: - Update "BSD" license declaration in cluster-gauges-qtcompositor and cluster-dasboard recipes to now required more specific "BSD-3-Clause" after checking in the source tree. - Make packagegroup-agl-profile-cluster-qtcompositor machine-specific to avoid tripping the new check for depending on dynamically renamed packages. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I24915cd85cb3854b3f9bc7947adda9cb5d42d8a9
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb2
-rw-r--r--recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 2f5bbecf..0f45d8f3 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "AGL demonstration instrument cluster dashboard application"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-dashboard"
SECTION = "apps"
-LICENSE = "Apache-2.0 & BSD"
+LICENSE = "Apache-2.0 & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
diff --git a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
index 4210754f..74f87ac8 100644
--- a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
+++ b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster gauges a
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-gauges"
SECTION = "apps"
-LICENSE = "Apache-2.0 & BSD"
+LICENSE = "Apache-2.0 & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://app/cluster-gauges.qml;beginline=10;endline=49;md5=54187d50b29429abee6095fe8b7c1a78"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb b/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb
index ba66b60d..0539ae12 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb
@@ -2,6 +2,8 @@ SUMMARY = "The middleware for AGL Qt5 based cluster qtcompositor"
DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Demo Qtcompositor Distribution"
LICENSE = "MIT"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
inherit packagegroup
PACKAGES = "\