summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2019-04-08 14:17:35 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-04-10 16:43:13 +0000
commitfb05d7e25a5444a554471247d8ce295fa4af3481 (patch)
treee846f78cbe1a55ba226a19beae237e7329586e77
parent096538a47325f6cae0684519f379da40ea0cf09e (diff)
Meta AGL demo: Added files for meta-agl-demo overviewguppy_7.0.1guppy/7.0.17.0.1
Change-Id: Ic0081ebc6a0ee07be46f81513c4ec817d706d1e4 Signed-off-by: Scott Rifenbark <srifenbark@gmail.com>
-rw-r--r--docs/devguides-book.yml6
-rwxr-xr-xmeta-agl-demo.md161
2 files changed, 164 insertions, 3 deletions
diff --git a/docs/devguides-book.yml b/docs/devguides-book.yml
index 58c2847f..23a182de 100644
--- a/docs/devguides-book.yml
+++ b/docs/devguides-book.yml
@@ -6,8 +6,8 @@ books:
description: Meta AGL Demo documentation
keywords:
author: "AGL"
- version: master
+ version: guppy
chapters:
- - url: ../README.md
+ - url: ../meta-agl-demo.md
destination: meta-agl-demo.md
- name: meta-agl-demo \ No newline at end of file
+ name: meta-agl-demo
diff --git a/meta-agl-demo.md b/meta-agl-demo.md
new file mode 100755
index 00000000..5e3321b7
--- /dev/null
+++ b/meta-agl-demo.md
@@ -0,0 +1,161 @@
+## Introduction
+
+The `meta-agl-demo` layer is the reference user interface layer for the DEMO
+platform of Automotive Grade Linux (AGL).
+The layer provides a reference platform and applications.
+The BitBake target name for the DEMO platform is `agl-demo-platform`, which is
+the full DEMO platform image.
+
+## Layer Dependencies
+
+This section describes dependencies for the `meta-agl-demo` layer.
+Dependencies are grouped into base, hardware, and feature dependencies.
+
+### Base Dependencies
+
+The `meta-agl-demo` layer has the following base dependencies:
+
+* Yocto Project Release:
+
+ - URI: git://git.yoctoproject.org/poky
+ - Branch: "rocko"
+ - Tested Revision: TBD
+
+* AGL `meta-agl` Layer:
+
+ - URI: https://gerrit.automotivelinux.org/gerrit/AGL/meta-agl
+ - Branch: "flounder"
+
+* OpenEmbedded `meta-openembedded` Layer:
+
+ - Branch: "rocko"
+ - Tested Revision: TBD
+
+ Specifically, out of `meta-openembedded`, these sub-layers are used:
+
+ - `meta-oe`
+ - `meta-multimedia`
+ - `meta-efl`
+ - `meta-networking`
+ - `meta-python`
+ - `meta-ruby`
+
+* Yocto Project `meta-qt5` Layer from the
+ [OpenEmbedded Layer Index](https://layers.openembedded.org/layerindex/branch/master/layers/):
+
+ - URI: https://github.com/meta-qt5/meta-qt5.git
+ - Branch: "rocko"
+ - Tested Revision: TBD
+
+### Hardware Dependencies
+
+Aside from the previously listed base dependencies, if you are using a
+[supported Renesas board](../../../../getting_started/en/dev/reference/machines/renesas.html)
+supported Renesas board, these dependencies exist:
+
+* AGL's `meta-renesas` Layer:
+
+ - URI: https://gerrit.automotivelinux.org/gerrit/AGL/meta-renesas
+ - Branch: "agl-1.0-bsp-1.8.0"
+ - Tested Revision: 82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (or later)
+
+### Feature Dependencies
+
+**The `agl-appfw-smack` Feature:**
+
+<!--
+* Yocto Project `meta-intel-iot-security` Layer from the OpenEmbedded Layer Index:
+
+ - URI: https://github.com/01org/meta-intel-iot-security
+ - Branch: "rocko"
+ - Tested Revision: TBD
+-->
+
+* Yocto Project `meta-security` Layer:
+
+ - URI: https://git.yoctoproject.org/cgit/cgit.cgi/meta-security
+ - Branch: "rocko"
+ - Tested Revision: TBD
+
+* AGL's `meta-app-framework` Layer Within the `meta-agl-extra` Layer:
+
+ - URI: https://gerrit.automotivelinux.org/gerrit/gitweb?p=AGL/meta-agl-extra.git
+ - Branch: "master"
+
+**The `agl-sota` Feature:**
+
+* AGL's `meta-sota` Layer Within the `meta-agl-extra` Layer:
+
+ - URI: https://gerrit.automotivelinux.org/gerrit/gitweb?p=AGL/meta-agl-extra.git
+ - Branch: "master"
+
+* OpenEmbedded's `meta-openembedded` Layer:
+
+ - URI: https://github.com/openembedded/meta-openembedded
+ - Branch: "rocko"
+ - Tested Version: TBD
+
+ In particular, the `meta-openembedded` layer depends on the following
+ sub-layers:
+
+ - `meta-filesystems`
+ - `meta-ruby`
+
+* OpenEmbedded's `meta-rust` Layer:
+
+ - URI: https://github.com/meta-rust/meta-rust
+ - Branch: "rocko"
+ - Tested Revision: TBE
+
+**The `agl-netboot` Feature:**
+
+* AGL's `meta-netboot` Layer Within the `meta-agl` Layer:
+
+ - URI: https://gerrit.automotivelinux.org/gerrit/gitweb?p=AGL/meta-agl.git
+ - Branch: "master"
+
+
+## Packagegroups
+
+AGL DEMO Platform's
+[packagegroups](https://www.yoctoproject.org/docs/2.4.4/dev-manual/dev-manual.html#usingpoky-extend-customimage-customtasks)
+consist of the following:
+
+### packagegroup-agl-demo-platform
+
+This packagegroup is used for generating the `agl-demo-platform` image,
+which is the full image for the AGL distributions IVI profile.
+You can see the recipe (i.e. `agl-demo-platform.bb`) that installs
+the `packagegroup-agl-demo-platform` packagegroup
+[here](https://git.automotivelinux.org/AGL/meta-agl-demo/tree/recipes-platform/images/agl-demo-platform.bb).
+
+As meta-agl's design of packagegroups, the `agl-demo-platform.bb` recipe installs
+only `packagegroup-agl-demo-platform` and the packages of the DEMO applications.
+
+``agl-demo-platform`` contains the following four packagegroups:
+
+ * `packagegroup-agl-image-minimal`
+ * `packagegroup-agl-image-ivi`
+ * `packagegroup-ivi-common-core`
+ * `packagegroup-agl-demo-platform`
+
+### packagegroup-agl-appfw*
+
+These packagegroups contain packages for the AGL distribution's
+Application Framework.
+Subsystem should maintain `packagegroup-agl-appfw-[subsystem].bb`, which
+should hold sufficient packages for the Application Framework.
+
+Subsystems also can maintain their own packagegroups using appropriate
+`recipes-*/`.
+For example, Qt5 has two packagegroups in `meta-agl-demo`:
+`packagegroup-agl-appfw-native-qt5` and `packagegroup-agl-demo-qt-examples`,
+which are under `recipes-qt/`.
+
+The `packagegroup-agl-appfw-native-qt5` is included by
+`packagegroup-agl-appfw-native` because Qt5 belongs to native application
+framework of AGL Distro.
+
+Because the `packagegroup-agl-demo-qt-examples` is not mandatory for
+the AGL Application Framework and the AGL DEMO, the packagegroup is added
+to the layer's `local.conf` file only when needed.