summaryrefslogtreecommitdiffstats
path: root/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-config/agl-login-manager/agl-login-manager_0.1.bb
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-config/agl-login-manager/agl-login-manager_0.1.bb')
-rw-r--r--recipes-config/agl-login-manager/agl-login-manager_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
new file mode 100644
index 00000000..49efce79
--- /dev/null
+++ b/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "AGL Login manager"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+LOGIN_USER ??="1001 1002"
+
+RDEPENDS_${PN} += "af-main"
+
+do_install_append() {
+
+ install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
+
+ for AGL_USER in ${LOGIN_USER};do
+ ln -s ../afm-user-session@.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-user-session@${AGL_USER}.service
+ done
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"