summaryrefslogtreecommitdiffstats
path: root/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-06 18:35:50 -0500
committerScott Murray <scott.murray@konsulko.com>2021-01-12 15:43:44 +0000
commit602966ea9205b5bc2c29946952afb54b7fdbcf47 (patch)
treef8ecab6200e92651e5b64e4de68ce1d43d9c1d40 /recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
parent161b988ccac63ce2c92acff0917e2ea811770c28 (diff)
Add dev-mapping-ci recipe
Add a dev-mapping-ci recipe that installs a CI specific version of /etc/dev-mapping.conf for the agl-service-can-low-level binding. Additionally, the dev-mapping-demo recipe files have been moved to recipes-config/dev-mapping so all the dev-mapping* recipes are in the same place, and the now required "j1939" bus mapping has been added to the various dev-mapping files. To enable use of the new recipe, a definition of the variable PREFERRED_RPROVIDER_virtual/low-can-dev-mapping has been added to the agl-demo feature definition that enables it based on the AGLCI DISTRO_FEATURE. This is intended to replace the definition in poky-agl.conf, which will be removed in subsequent cleanup. Bug-AGL: SPEC-3756 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ieb80a7f4b76ddd7851acca521dea1a8dd104cf86
Diffstat (limited to 'recipes-config/dev-mapping/dev-mapping-demo_1.0.bb')
-rw-r--r--recipes-config/dev-mapping/dev-mapping-demo_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb b/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
new file mode 100644
index 00000000..4a04ce13
--- /dev/null
+++ b/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding for the AGL demo setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.demo"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"