summaryrefslogtreecommitdiffstats
path: root/recipes-config/qemu-config/qemu-config-vmnet0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-23 10:22:43 -0400
commit4ed1a0a0302cec13f12d3999466d62841c104402 (patch)
tree3800d3c40398a5441122e5b04bd6aeac6ee88945 /recipes-config/qemu-config/qemu-config-vmnet0.bb
parentfe2024e444f214ed6fd04c37d09c51f1c6a9e8e6 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-config/qemu-config/qemu-config-vmnet0.bb')
-rw-r--r--recipes-config/qemu-config/qemu-config-vmnet0.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-config/qemu-config/qemu-config-vmnet0.bb b/recipes-config/qemu-config/qemu-config-vmnet0.bb
index a5a12982..43712416 100644
--- a/recipes-config/qemu-config/qemu-config-vmnet0.bb
+++ b/recipes-config/qemu-config/qemu-config-vmnet0.bb
@@ -11,26 +11,29 @@ SRC_URI = "file://vmnet0.netdev \
file://connman-nodnsproxy.conf \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install systemd-networkd vmnet0 configuration
install -d ${D}${systemd_unitdir}/network
- install -m 0644 ${WORKDIR}/vmnet0.netdev ${D}${systemd_unitdir}/network/
- install -m 0644 ${WORKDIR}/vmnet0.network ${D}${systemd_unitdir}/network/
+ install -m 0644 ${UNPACKDIR}/vmnet0.netdev ${D}${systemd_unitdir}/network/
+ install -m 0644 ${UNPACKDIR}/vmnet0.network ${D}${systemd_unitdir}/network/
# Install QEMU bridge configuration
install -d ${D}${sysconfdir}/qemu
- install -m 0644 ${WORKDIR}/bridge.conf ${D}${sysconfdir}/qemu/
+ install -m 0644 ${UNPACKDIR}/bridge.conf ${D}${sysconfdir}/qemu/
# Configure dnsmasq to serve DHCP to the guests
install -d ${D}${sysconfdir}/dnsmasq.d
- install -m 0644 ${WORKDIR}/dnsmasq-qemu.conf ${D}${sysconfdir}/dnsmasq.d/
+ install -m 0644 ${UNPACKDIR}/dnsmasq-qemu.conf ${D}${sysconfdir}/dnsmasq.d/
# Disable ConnMan's local DNS proxy to not conflict with dnsmasq
install -d ${D}${systemd_system_unitdir}/connman.service.d/
- install -m 0644 ${WORKDIR}/connman-nodnsproxy.conf ${D}${systemd_system_unitdir}/connman.service.d/
+ install -m 0644 ${UNPACKDIR}/connman-nodnsproxy.conf ${D}${systemd_system_unitdir}/connman.service.d/
}
FILES:${PN} += "${systemd_unitdir}/network ${systemd_system_unitdir}"