summaryrefslogtreecommitdiffstats
path: root/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-config
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-config')
-rw-r--r--recipes-config/agl-login-manager/agl-login-manager_0.1.bb6
-rw-r--r--recipes-config/agl-users/agl-users_0.1.bb6
-rw-r--r--recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb2
-rw-r--r--recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb8
-rw-r--r--recipes-config/cluster-lin-bridging-config/cluster-lin-bridging-config.bb8
-rw-r--r--recipes-config/dev-mapping/dev-mapping-ci_1.0.bb2
-rw-r--r--recipes-config/dev-mapping/dev-mapping-demo_1.0.bb2
-rw-r--r--recipes-config/dev-mapping/dev-mapping_0.1.bb2
-rw-r--r--recipes-config/systemd-sync/systemd-agl-sync_1.0.bb2
-rw-r--r--recipes-config/unicens-config/unicens-config.bb8
10 files changed, 23 insertions, 23 deletions
diff --git a/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
index 49efce79..20ca1263 100644
--- a/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
+++ b/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
@@ -5,9 +5,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
LOGIN_USER ??="1001 1002"
-RDEPENDS_${PN} += "af-main"
+RDEPENDS:${PN} += "af-main"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
@@ -16,4 +16,4 @@ do_install_append() {
done
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-config/agl-users/agl-users_0.1.bb b/recipes-config/agl-users/agl-users_0.1.bb
index 709a1091..a1473a8e 100644
--- a/recipes-config/agl-users/agl-users_0.1.bb
+++ b/recipes-config/agl-users/agl-users_0.1.bb
@@ -7,20 +7,20 @@ DESCRIPTION = "This is a core framework component that\
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
USERADD_PACKAGES = "${PN}"
USERADDEXTENSION = "useradd-staticids"
-GROUPADD_PARAM_${PN} = "\
+GROUPADD_PARAM:${PN} = "\
--system display ; \
--system weston-launch ; \
-g 1001 agl-driver ; \
-g 1002 agl-passenger \
"
-USERADD_PARAM_${PN} = "\
+USERADD_PARAM:${PN} = "\
-g 1001 -u 1001 -o -d /home/1001 -m -K PASS_MAX_DAYS=-1 agl-driver ; \
-g 1002 -u 1002 -o -d /home/1002 -m -K PASS_MAX_DAYS=-1 agl-passenger ; \
--gid display --groups weston-launch,video,input --home-dir /run/platform/display --shell /bin/false --comment \"Display daemon\" --key PASS_MAX_DAYS=-1 display \
diff --git a/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb b/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
index ab725c05..8d737282 100644
--- a/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
+++ b/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
@@ -30,4 +30,4 @@ do_install() {
${D}${sysconfdir}/systemd/system/network.target.wants/cluster-demo-network-conf@${AGL_CLUSTER_NET_DEVICE}.service
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
index 593bdd59..2eaabc97 100644
--- a/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
+++ b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
@@ -7,8 +7,8 @@ SRC_URI = "file://cluster-demo-simulator.service"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "cluster-demo-simulator.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "cluster-demo-simulator.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
@@ -18,6 +18,6 @@ do_install() {
install -m 0644 ${WORKDIR}/cluster-demo-simulator.service ${D}${systemd_system_unitdir}
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS_${PN} = "simple-can-simulator"
+RDEPENDS:${PN} = "simple-can-simulator"
diff --git a/recipes-config/cluster-lin-bridging-config/cluster-lin-bridging-config.bb b/recipes-config/cluster-lin-bridging-config/cluster-lin-bridging-config.bb
index d03b91f3..5366f2d0 100644
--- a/recipes-config/cluster-lin-bridging-config/cluster-lin-bridging-config.bb
+++ b/recipes-config/cluster-lin-bridging-config/cluster-lin-bridging-config.bb
@@ -9,8 +9,8 @@ SRC_URI = "\
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "cluster-lin-bridging.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "cluster-lin-bridging.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
@@ -20,9 +20,9 @@ do_install() {
install -m 0644 ${WORKDIR}/cluster-lin-bridging.service ${D}${systemd_system_unitdir}
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
can-utils \
sllin \
"
diff --git a/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
index cbba5730..7b40e40c 100644
--- a/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
+++ b/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -15,4 +15,4 @@ do_install() {
install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
}
-RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"
diff --git a/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb b/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
index 4a04ce13..23fdc078 100644
--- a/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
+++ b/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
@@ -15,4 +15,4 @@ do_install() {
install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
}
-RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"
diff --git a/recipes-config/dev-mapping/dev-mapping_0.1.bb b/recipes-config/dev-mapping/dev-mapping_0.1.bb
index 1309ffa2..f880d39d 100644
--- a/recipes-config/dev-mapping/dev-mapping_0.1.bb
+++ b/recipes-config/dev-mapping/dev-mapping_0.1.bb
@@ -15,4 +15,4 @@ do_install() {
install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
}
-RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"
diff --git a/recipes-config/systemd-sync/systemd-agl-sync_1.0.bb b/recipes-config/systemd-sync/systemd-agl-sync_1.0.bb
index 389ab242..0b2dc4e4 100644
--- a/recipes-config/systemd-sync/systemd-agl-sync_1.0.bb
+++ b/recipes-config/systemd-sync/systemd-agl-sync_1.0.bb
@@ -36,4 +36,4 @@ EOF
chmod a+x ${D}/${sysconfdir}/agl-postinsts/${POST_INSTALL_SCRIPT}
}
-FILES_${PN} = "${sysconfdir}/agl-postinsts/${POST_INSTALL_SCRIPT}"
+FILES:${PN} = "${sysconfdir}/agl-postinsts/${POST_INSTALL_SCRIPT}"
diff --git a/recipes-config/unicens-config/unicens-config.bb b/recipes-config/unicens-config/unicens-config.bb
index 4dd20748..57b93a76 100644
--- a/recipes-config/unicens-config/unicens-config.bb
+++ b/recipes-config/unicens-config/unicens-config.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Configure MOST driver"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
SRC_URI = "\
file://unicens-config.service \
@@ -14,8 +14,8 @@ SRC_URI = "\
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "unicens-config.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "unicens-config.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
@@ -28,4 +28,4 @@ do_install() {
install -D -m 0644 ${WORKDIR}/55-inic.rules ${D}${sysconfdir}/udev/rules.d/55-inic.rules
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"