summaryrefslogtreecommitdiffstats
path: root/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 18:06:42 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:00:05 -0400
commit78883948a2f9ee25ebc24c6fcfefd031d0d3cb6f (patch)
tree16404d69184c0005595873c88cf076598f72ae7d /recipes-config
parentbd151bb0aa5d5492839fa23a8872014e67425771 (diff)
Rework demo packagegroup and images
Rework the agl-ivi-demo-platform* images to reduce duplication, and move the additions for the agl-demo-cluster-support and agl-demo-preload features. Changes: - Pull in agl-image-ivi.bb in the crosssdk image rather than duplicating its contents. This means the package additions from the demo features will be reflected in the SDK, which seems more in line with general expectations of how Yocto SDKs work. - New packagegroups are created for the agl-demo-cluster-support and agl-demo-preload features, and they are pulled into the agl-ivi-demo-platform / agl-demo-platform image using features in IMAGE_FEATURES. This avoids changing the contents of various packagegroups based on AGL_FEATURES and seems more futureproof with respect to binary packaging. - ALLOW_EMPTY has been removed in a few packagegroup recipes, as it does not seem to make sense if the packagegroup will never be empty. - The cluster-dashboard-demo-config recipe pulled into the agl-demo-cluster-support packagegroup has been added back, it was accidentally removed in the application framework cleanup. Bug-AGL: SPEC-4424 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Icaa38651a1d29de09bb40576c773e3f93ee87098
Diffstat (limited to 'recipes-config')
-rw-r--r--recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb11
-rw-r--r--recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb b/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb
new file mode 100644
index 00000000..f1fce78f
--- /dev/null
+++ b/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL cluster demo dashboard configuration file"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://AGL.conf.cluster"
+
+inherit allarch
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/AGL.conf.cluster ${D}${sysconfdir}/xdg/AGL.conf
+}
diff --git a/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster b/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster
new file mode 100644
index 00000000..dd8a912c
--- /dev/null
+++ b/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster
@@ -0,0 +1,2 @@
+[dashboard]
+animation=false