summaryrefslogtreecommitdiffstats
path: root/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-03-02 10:55:44 -0500
committerScott Murray <scott.murray@konsulko.com>2021-03-02 15:42:58 -0500
commita4afe6819819f040ee5f85e01249026a00f781bb (patch)
treec5f7d8cdc048af18cc89a18ef53e0f31d9861de4 /recipes-config
parent7527e582ca5517d4fa9e3a40a0f2eeabe9d8069e (diff)
cluster-demo-simulator: update LICENSE/LIC_CHKSUM_FILE
Upstream has renamed the common license files, but investigation revealed that the LICENSE on this purely configuration recipe should likely be MIT to be consistent with the other similar recipes in the tree, so update both LICENSE and LIC_CHKSUM_FILE to fix both issues. As well, now that the demo repositories are merged, this recipe can just RDEPEND on simple-can-simulator, rather than duplicating it. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2302e904258a67d3c2a1756f94d247e3779106f0
Diffstat (limited to 'recipes-config')
-rw-r--r--recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
index 171ea167..593bdd59 100644
--- a/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
+++ b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
@@ -1,11 +1,8 @@
-DESCRIPTION = "Simulate can messages of a driving car"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DESCRIPTION = "Systemd unit to start simple CAN simulator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-SRC_URI = "\
- file://cluster-demo-simulator.service \
- file://simple_can_simulator.py \
-"
+SRC_URI = "file://cluster-demo-simulator.service"
inherit systemd
@@ -19,13 +16,8 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/cluster-demo-simulator.service ${D}${systemd_system_unitdir}
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/simple_can_simulator.py ${D}${sbindir}
}
FILES_${PN} += "${systemd_system_unitdir}"
-RDEPENDS_${PN} = " \
- can-utils \
- python3 \
-"
+RDEPENDS_${PN} = "simple-can-simulator"