summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-30 16:52:16 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 09:55:31 +0000
commit1fb690465a3704a7a492495ff2606c4edb46b902 (patch)
treebcbb72bfab3575877b5df727fac8a973166ce110 /recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb
parenta87c7d82262ba9e88f589acfa8c92f2b6076c0eb (diff)
Add KUKSA.val databroker
Add a recipe for the KUKSA.val databroker, a Rust implementation of a VSS server with gRPC APIs, and add it to the images that currently have the C++ kuksa-val server to ease further integration development. Since the databroker listens for gRPC API requests on a different port than the C++ server, there is no conflict during this period. Users wanting to drive CAN data into the databroker for testing will have to manually update the kuksa-dbc-feeder configuration during this interim period. Changes: - Bump common KUKSA.val SRCREV to pick up some improvements. - Add kuksa-databroker recipe to build the databroker. - Add kuksa-databroker-agl recipe to install AGL-specific configuration for the databroker, similar to what has previously been done with kuksa-val-agl for the C++ server. - Add missing branch node declarations in the AGL VSS overlay, as the databroker VSS parser is stricter and treats their absence as an error. - Add the kuksa-databroker, kuksa-databroker-agl, and the kuksa-databroker-cli packages to the appropriate packagegroups and images. Some follow up work will factor out a packagegroup for the KUKSA.val packages to make future changes easier. Bug-AGL: SPEC-4762 Change-Id: Ie7837b7e42a2283914adc913b75639fcb83029a6 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb b/recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb
new file mode 100644
index 00000000..2cee2930
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-databroker-agl.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL options for KUKSA.val databroker"
+HOMEPAGE = "https://github.com/eclipse/kuksa.val"
+BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://kuksa-databroker.env"
+
+inherit allarch update-alternatives
+
+do_install() {
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/kuksa-databroker.env ${D}${sysconfdir}/default/kuksa-databroker.agl
+}
+
+ALTERNATIVE:${PN} = "kuksa-databroker-env"
+ALTERNATIVE_LINK_NAME[kuksa-databroker-env] = "${sysconfdir}/default/kuksa-databroker"
+ALTERNATIVE_TARGET[kuksa-databroker-env] = "${sysconfdir}/default/kuksa-databroker.agl"
+
+RDEPENDS:${PN} += "kuksa-databroker kuksa-certificates-agl vss-agl"