summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 20:05:49 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:00:05 -0400
commitce5cd75dd87565f6d9ee81432344a1d66aab42bf (patch)
tree7bce27c830ac17e3d7f953f7c9c6be11c4d35a17 /recipes-connectivity
parent34507cc363eb04bfae36f9a1e9606c32ad5f719c (diff)
kuksa-val: split client certificates into a separate package
Split the certificates required by clients (so client and CA) into a separate kuksa-val-client-certificates package so that they can be reused in the cluster demo image without having the full KUKSA.val server installed. Bug-AGL: SPEC-4405 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6b78b212ead395c8f731eab40ef0525a515bdb7c
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-val_git.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-val_git.bb b/recipes-connectivity/kuksa-val/kuksa-val_git.bb
index 033e81e0..a8e2c31f 100644
--- a/recipes-connectivity/kuksa-val/kuksa-val_git.bb
+++ b/recipes-connectivity/kuksa-val/kuksa-val_git.bb
@@ -40,7 +40,7 @@ EXTRA_OECMAKE = " \
do_install:append() {
# Lower the logging level used in the installed config.ini from the upstream
- # default of "ALL", which seems to cause performance issues at the moment.
+ # default of "ALL", which spams the logs.
sed -i 's/^log-level = .*/log-level = WARNING/' ${D}/${sysconfdir}/kuksa-val/config.ini
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
@@ -58,5 +58,17 @@ do_install:append() {
chgrp 900 ${D}${sysconfdir}/kuksa-val/Server.pem
}
+# Put client certificates into their own package so we can avoid
+# duplicates of them for e.g. cluster clients. Longer term this
+# will need to be revisited.
+PACKAGE_BEFORE_PN += "${PN}-client-certificates"
+
+FILES:${PN}-client-certificates = " \
+ ${sysconfdir}/kuksa-val/Client.key \
+ ${sysconfdir}/kuksa-val/Client.pem \
+ ${sysconfdir}/kuksa-val/CA.pem \
+"
+
FILES:${PN} += "${systemd_system_unitdir} ${datadir}"
+RDEPENDS:${PN} += "${PN}-client-certificates"