summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-12 17:23:58 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-13 20:35:47 +0000
commitfec097c007277ffcfb4eeae9dab9a4b5baf07868 (patch)
tree122c2a37f089177a47622424158f23e84b9e82b7 /recipes-connectivity
parentd7d6c8622195aaf83bd66b53dec231d7b1c30bf1 (diff)
Update agl-cluster-demo-support feature
Changes: - Switch agl-cluster-demo-support from using IMAGE_FEATURES to AGL_FEATURES to work better with building the different demo images. - Add a connman bbappend to move the agl-cluster-demo-support specific logic out of meta-agl-core. Bug-AGL: SPEC-3749 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Iad42662db903b7403ec7985c315793fdcd6fc9a7
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend1
-rw-r--r--recipes-connectivity/connman/connman_agldemo.inc6
2 files changed, 7 insertions, 0 deletions
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
new file mode 100644
index 00000000..9bcba76c
--- /dev/null
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'connman_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/connman/connman_agldemo.inc b/recipes-connectivity/connman/connman_agldemo.inc
new file mode 100644
index 00000000..1900cc14
--- /dev/null
+++ b/recipes-connectivity/connman/connman_agldemo.inc
@@ -0,0 +1,6 @@
+do_install_append() {
+ # Need to ignore eth1 in cluster demo setup
+ if ${@bb.utils.contains('AGL_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
+ sed -i 's/^\(NetworkInterfaceBlacklist=.*\)/\1,eth1/' ${D}${sysconfdir}/connman/main.conf
+ fi
+}