summaryrefslogtreecommitdiffstats
path: root/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-19 06:07:28 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-29 13:35:09 +0000
commit9f82d40210944ffb2fae5e8435f5269807a6b384 (patch)
tree98126dd4eaf32e41d7b91a61cbc0bfec2bd8132d /recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
parent0d92a75ac38965766389a9e5f172c70d7680792d (diff)
A fstab replacement method change to build container guest
In https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/28690 review, I got a request for method change request. Existing method use bbappend for base files. New method use ROOTFS_POSTPROCESS_COMMAND. Bug-AGL: SPEC-4803 Change-Id: Ie058ef55f7dfeae5d651b46d5ff731d1a2bebc19 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb')
-rw-r--r--recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
new file mode 100644
index 00000000..ad3e6e94
--- /dev/null
+++ b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Container guest extention for fstab"
+DESCRIPTION = "The base-files-guest-fstab package creates the fstab for container guest integration."
+SECTION = "base"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = " \
+ file://fstab \
+"
+S = "${WORKDIR}"
+
+#INHIBIT_DEFAULT_DEPS = "1"
+
+do_install () {
+ install -m 0755 -d ${D}${sysconfdir}
+
+ install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab-guest
+}
+
+PACKAGES = "${PN}"
+FILES:${PN} = "${sysconfdir}/fstab-guest"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES:${PN} = "${sysconfdir}/fstab-guest"