summaryrefslogtreecommitdiffstats
path: root/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:56:32 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:56:32 +0100
commita7ed1887b82ee27c9ae6aef39a4a5067195fd129 (patch)
tree6effb517fef6b5bf770080da8343b4e7185ec8fc /recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
parent91964e64690d7c69db8a9f2cd0cb0110f1089e05 (diff)
parentbdc9eb3b8a48315fe5df4fabb0ca53b98bbc1808 (diff)
Merge remote-tracking branch 'agl/sandbox/locust2001/rocko' into HEAD
* agl/sandbox/locust2001/rocko: ninja,harfbuzz: Remove .bbappend libdbus-c++:Fix build error in GCC-7 qtbase: Remove -no-use-gold-linker option unicens-config: Add bash to rdeps libdbus-c++: Remove bbappend file opencv: Rename .bbappend to match new version from meta-openembedded Bug-AGL: SPEC-1181 Change-Id: I0fc0ee1e50dc20b57b943b7128d157d51eb9cafa Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch')
-rw-r--r--recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch b/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
new file mode 100644
index 00000000..c4fafef6
--- /dev/null
+++ b/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
@@ -0,0 +1,45 @@
+--- libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h.threading 2017-02-15 13:40:53.796004263 +0000
++++ libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h 2017-02-15 13:40:46.907000493 +0000
+@@ -188,6 +188,7 @@
+ /* classes for multithreading support
+ */
+
++#if 0
+ class DXXAPI Mutex
+ {
+ public:
+@@ -243,9 +244,11 @@
+ typedef bool (*CondVarWaitTimeoutFn)(CondVar *cv, Mutex *mx, int timeout);
+ typedef void (*CondVarWakeOneFn)(CondVar *cv);
+ typedef void (*CondVarWakeAllFn)(CondVar *cv);
++#endif
+
+ void DXXAPI _init_threading();
+
++#if 0
+ void DXXAPI _init_threading(
+ MutexNewFn, MutexFreeFn, MutexLockFn, MutexUnlockFn,
+ CondVarNewFn, CondVarFreeFn, CondVarWaitFn, CondVarWaitTimeoutFn, CondVarWakeOneFn, CondVarWakeAllFn
+@@ -312,6 +315,7 @@
+ cv->wake_all();
+ }
+ };
++#endif
+
+ } /* namespace DBus */
+
+--- libdbus-c++-0.9.0/src/dispatcher.cpp.threading 2017-02-15 13:48:22.627249868 +0000
++++ libdbus-c++-0.9.0/src/dispatcher.cpp 2017-02-15 13:48:29.164253445 +0000
+@@ -253,6 +253,7 @@
+ #endif//DBUS_HAS_THREADS_INIT_DEFAULT
+ }
+
++#if 0
+ void DBus::_init_threading(
+ MutexNewFn m1,
+ MutexFreeFn m2,
+@@ -318,3 +319,4 @@
+ #endif//DBUS_HAS_RECURSIVE_MUTEX
+ dbus_threads_init(&functions);
+ }
++#endif