summaryrefslogtreecommitdiffstats
path: root/recipes-core/nss
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-29 22:17:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-29 22:17:45 +0200
commit1e62ea70abd523482e4a181737e7202280a30ce3 (patch)
tree5efe4d3b0a0368338d1ab68d8168981d6a84c2d9 /recipes-core/nss
parentdea014d480e5a3ed81953c13e95e806d139e7092 (diff)
Fix for user and group of /home/agl-driver
The private nssdb introduced wrong access rights for /home/agl-driver through the package. Fix it till we have it reworked. Bug-AGL: SPEC-4599 Change-Id: I665b51f8473f64785c64c55359b5e0e702050e9a Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-core/nss')
-rw-r--r--recipes-core/nss/nss-agl-driver-db_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-core/nss/nss-agl-driver-db_git.bb b/recipes-core/nss/nss-agl-driver-db_git.bb
index ba203d4e..3d8aa5f4 100644
--- a/recipes-core/nss/nss-agl-driver-db_git.bb
+++ b/recipes-core/nss/nss-agl-driver-db_git.bb
@@ -12,10 +12,11 @@ do_compile[noexec] = "1"
do_install() {
mkdir -p ${D}/home/agl-driver/.pki/nssdb
certutil -N -d ${D}/home/agl-driver/.pki/nssdb --empty-password
+ chown -R 1001:1001 ${D}/home/agl-driver
}
pkg_postinst_ontarget:${PN} () {
- chown agl-driver:agl-driver -R /home/agl-driver/.pki/
+ chown agl-driver:agl-driver -R /home/agl-driver/
}
FILES:${PN} += "/home/agl-driver/.pki/*"