summaryrefslogtreecommitdiffstats
path: root/recipes-core/psplash
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-21 18:32:35 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-22 12:26:00 +0000
commit6dc0e32fbda2c122a2b59630d774dc4ef1a49619 (patch)
treefe12e1df442a0606dfc2c5584eaaf5f6be8afb7f /recipes-core/psplash
parente9aff80fda75723360d070793e645a8db541b8bf (diff)
KVM demo updates
Changes: - Fix native-shell-client systemd unit to work with the changes made for SPEC-4714 (separate agl-compositor systemd unit, running as agl-driver). - Update agl-qemu-runner.sh for the SPEC-4714 changes. - Tweak cluster guest configuration to use just 2 cores and 1 GB of memory to free up resources for the host. - Add inverted psplash configuration that is pulled in for the KVM demo image when building with agl-demo-preload. This matches the inverted screen in the demo hardware. Bug-AGL: SPEC-4974 Change-Id: Ie57a3550c8c8b12fd64ee14a9f1fbf4a4c40da32 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29460 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-core/psplash')
-rw-r--r--recipes-core/psplash/files/psplash-inverted.conf2
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb20
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-core/psplash/files/psplash-inverted.conf b/recipes-core/psplash/files/psplash-inverted.conf
new file mode 100644
index 00000000..440db891
--- /dev/null
+++ b/recipes-core/psplash/files/psplash-inverted.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PSPLASH_ANGLE_ARGS='--angle 180'
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
new file mode 100644
index 00000000..f11b255d
--- /dev/null
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Systemd unit override for psplash inverted mode for the AGL Demonstrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://psplash-inverted.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "psplash"