summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:46:02 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit63e0ea358f1902b1dd9968b21b5eea649d04329e (patch)
tree4231493c300f4d9ea2c84b6e290919486bf7e0b6 /recipes-core
parent9eda76e3a9c869030ff4bcf66704207753666a6c (diff)
Move html5 demo into sublayer
The HTML5 demo needs additional fixes. Move it into a sublayer and activate with agl-demo-html5. Bug-AGL: SPEC-5188 Change-Id: I2f1a07dcfbcaf7e09d4d0d3aec1aa8f096336287 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30042 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Scott Murray <scott.murray@konsulko.com> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.service12
-rwxr-xr-xrecipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.sh19
-rw-r--r--recipes-core/nss/nss-agl-driver-db_git.bb32
3 files changed, 0 insertions, 63 deletions
diff --git a/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.service b/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.service
deleted file mode 100644
index 40818cf2..00000000
--- a/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Deploy Kuksa certificates to /home/agl-driver/.pki/
-After=local-fs.target
-Before=multi-user.target
-ConditionPathExists=!/home/agl-driver/.pki
-
-[Service]
-User=agl-driver
-ExecStart=/usr/sbin/nss-agl-driver-db.sh
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.sh b/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.sh
deleted file mode 100755
index 1a8351bf..00000000
--- a/recipes-core/nss/nss-agl-driver-db/nss-agl-driver-db.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/bash
-set -e
-
-# TLDR we need this file for chromium to connect back to kuksa.
-
-# check if directory already exists and bail out
-if test -d /home/agl-driver/.pki/nssdb ; then
- echo "Directory already exists! Doing nothing."
- exit 127
-fi
-
-# setup empty db in subfolder
-mkdir -p /home/agl-driver/.pki/nssdb
-certutil -N -d /home/agl-driver/.pki/nssdb --empty-password
-
-# deploy cert into local db
-certutil -A -d /home/agl-driver/.pki/nssdb -n "KuksaRootCA" -t "pC,," -i /etc/kuksa-val/CA.pem
-
-#chown -R agl-driver:agl-driver /home/agl-driver/.pki/nssdb
diff --git a/recipes-core/nss/nss-agl-driver-db_git.bb b/recipes-core/nss/nss-agl-driver-db_git.bb
deleted file mode 100644
index b2fb4034..00000000
--- a/recipes-core/nss/nss-agl-driver-db_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "Custom nss db hosting the kuksa certificates"
-DESCRIPTION = "Custom nss db hosting the kuksa certificates for chromium"
-AUTHOR = "Jan-Simon Moeller <jsmoeller@linuxfoundation.org>"
-HOMEPAGE = "https://git.automotivelinux.org"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-PV = "0.1"
-
-SRC_URI = "file://${BPN}.service \
- file://${BPN}.sh \
- "
-
-inherit systemd
-
-SYSTEMD_SERVICE:${PN} = "${BPN}.service"
-
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -d ${D}${sbindir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}
- fi
-}
-
-FILES:${PN} += "${systemd_system_unitdir} ${sbindir}"
-
-RDEPENDS:${PN} += "nss agl-users kuksa-val-certificates-client bash"