summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2016-12-28 15:49:09 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-28 23:04:19 +0000
commit2b0029244a4abee48ac42b0d28d25eacff07e26c (patch)
tree0527ae1a8ae20a351c62fd693bf41b005961a529 /recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
parent902589932c94a9c9112fa34f25b6ea867e20bc39 (diff)
ces2017-demo: add install of presets configuration file for Radio app
Add preset configuration files for the Radio app for CES and ALS locations, and commands to install the one selected with a new variable, AGL_RADIO_PRESETS_LOCALE. The default is to use the presets appropriate for CES. Change-Id: I9b278e1c983de16898fc71329afe7c6ba58e9b52 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/CES2017-demo/CES2017-demo.bb')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index e66a9600..a81ceaf1 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -12,9 +12,12 @@ DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
-SRCREV = "${AUTOREV}"
+AGL_RADIO_PRESETS_LOCALE ?= "CES"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
+ file://presets-${AGL_RADIO_PRESETS_LOCALE}.conf \
+"
+SRCREV = "${AUTOREV}"
RDEPENDS_${PN} += " \
qtmultimedia-qmlplugins \
@@ -88,7 +91,6 @@ do_install_prepend() {
zip radio.wgt config.xml radio
-
cat > ${B}/apps/installAllApps.sh <<-EOF
#!/bin/sh
cd /usr/AGL/apps
@@ -111,6 +113,8 @@ do_install() {
install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
+ install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
ln -sf ../apps/installAllApps.sh ${D}/usr/AGL/${PN}/installAllApps.sh
@@ -146,6 +150,7 @@ do_install() {
FILES_${PN} += "/usr/AGL/ \
/usr/AGL/apps/* \
/usr/AGL/${PN}/* \
+ /home/root/app-data/radio/presets.conf \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
/usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \