summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/dashboard
diff options
context:
space:
mode:
authorTasuku Suzuki <tasuku.suzuki@qt.io>2017-11-22 09:31:41 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 13:25:45 +0000
commit64b28dd3f4004a6c651b96513820e39f6d0b8c69 (patch)
treed0f27a60eaf12c891ce31f8f79da4c0ceb20588a /recipes-demo-hmi/dashboard
parent61053e4758f84b2221000abeed7ce6191fc8a344 (diff)
Add build time dependency to qttools-native
To support i18n, the project will need the command called lrelease which is in qttools. Change-Id: Ic5a83b5483f27d1260a123ef559b99425f4058e4 Signed-off-by: Tasuku Suzuki <tasuku.suzuki@qt.io>
Diffstat (limited to 'recipes-demo-hmi/dashboard')
-rw-r--r--recipes-demo-hmi/dashboard/dashboard_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-demo-hmi/dashboard/dashboard_git.bb b/recipes-demo-hmi/dashboard/dashboard_git.bb
index 795e9e12..289b4482 100644
--- a/recipes-demo-hmi/dashboard/dashboard_git.bb
+++ b/recipes-demo-hmi/dashboard/dashboard_git.bb
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager qttools-native"
inherit qmake5 aglwgt
+
+do_configure_append() {
+ # Find native tools
+ sed -i 's:${STAGING_BINDIR}.*/lrelease:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/lrelease:g' ${B}/app/Makefile
+}