summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/homescreen
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2018-07-10 18:49:23 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-11 19:42:44 +0000
commit656b5812bfa4ad86833a5c11444101df4a9de85f (patch)
treeccb3b0b9b38c1e9f7dc7b4308d8bc1114a45afb3 /recipes-demo-hmi/homescreen
parent8d8a0c5abe794c9cfea4a81400a397929be1b875 (diff)
Change homescreen recipes to fit homescreen-2017
We copied homescreen-2017 source code to homescreen. Need change recipes for this commit. Relative Commit: https://gerrit.automotivelinux.org/gerrit/#/c/15173/ Bug-AGL: SPEC-1549 Change-Id: I3455feb630b64d04c402855df0d6dce34cd62fcc Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'recipes-demo-hmi/homescreen')
-rw-r--r--recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in6
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb55
2 files changed, 20 insertions, 41 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in b/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in
deleted file mode 100644
index a79d70f7..00000000
--- a/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0"?> <!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy context="default">
- <allow send_destination="org.agl.homescreen"/>
- </policy>
-</busconfig>
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index e7d07cf6..f9b02e9f 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -1,44 +1,29 @@
SUMMARY = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate"
+DESCRIPTION = "AGL Home Screen Application build with recipe method"
HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "apps"
-S = "${WORKDIR}/git/"
-
-inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase qtdeclarative qtquickcontrols2 pulseaudio"
-RDEPENDS_${PN} = " \
- homescreenappframeworkbinderagl \
- inputeventmanager \
- windowmanager"
-
LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=https;branch=${AGL_BRANCH} \
- file://dbus-homescreen.conf.in"
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ pulseaudio \
+ agl-service-homescreen-2017 \
+ agl-service-windowmanager-2017 \
+ agl-service-weather \
+ libqtappfw \
+ qlibwindowmanager \
+ virtual/libhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
-
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
-
-do_install() {
- install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${B}/homescreen/HomeScreen ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/sampleapptimedate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
-# claneys: add dbus policy to make wifi/bluetooth status icon working as quick
-# workaround. (jira.automotivelinux.org : SPEC-377)
- install -d ${D}/etc/dbus-1/session.d
- install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
-
- install -d ${D}${systemd_user_unitdir}
- install -m 0644 ${S}/homescreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
-
- install -d ${D}${sysconfdir}/systemd/user/default.target.wants
- ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
-}
-
-FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
-FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"