summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/homescreen
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2018-08-14 10:54:15 -0400
committerMatt Porter <mporter@konsulko.com>2018-08-14 10:57:00 -0400
commitd852283d45400c8a6b0714d3f364b8da86bbfe5e (patch)
treedcd2a9af1c079861dd75c3718f7ea1c0004b5260 /recipes-demo-hmi/homescreen
parent096d1487b5c1441595bc0700b089e3bc011cbdf4 (diff)
Revert "Remove Deprecated recipes homescreen"
This reverts commit 8d853962f123472f0e7217789f80c10c0191ade5. homescreen recipe is required by the recently merged switch from homescreen-2017 to homescreen. Change-Id: I53e3d7378bf2f2fbe2953d821676dfeda12ff034 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/homescreen')
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
new file mode 100644
index 00000000..f9b02e9f
--- /dev/null
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application build with recipe method"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ pulseaudio \
+ agl-service-homescreen-2017 \
+ agl-service-windowmanager-2017 \
+ agl-service-weather \
+ libqtappfw \
+ qlibwindowmanager \
+ virtual/libhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"